SKETCHUP DERS NOTLARI — PROF. DR. SALIiH OFLUOGLU

03. Olgiilii ve Verimli Calismak

Bu baslik altinda bir kenar1 referans alarak diiz veya a¢ili mesafe girerek varliklar olusturma ve ¢izim
elemanlarin grup ve bilesenler olarak ayirarak esnek calisma imkani veren secenekler anlatilacaktir..

Tape Measure Araci

Cizim lizerinde mesafe 6l¢mek ve varolan kenarlari referans alarak ytizeyler ve serbest alanlar
vp tizerinde kilavuz ¢izgiler koyarak yeni varliklar olusturmak i¢in kullanilir.

Kilavuz cizgi yerlestirmek icin Tape Measure aracina tiklanir. ilgili kenara tiklanir ve imle¢ hareket
ettirilerek birakilir. Length degeri girilerek mesafe tamamlanir. Bu olusturulan kilavuz ¢izgilerden cizgiler
gecililir. P

-+
--4

Kilavuz cizgileri varligin disinda bir yerde de olusturulabilir.

e Kilavuz cizgileri gecici olarak View-> Guides ile kapatilabilir.
e Kilavuz cizgileri tek tek secilerek silinebilir.
e Tim kilavuz cizgileri istenirse Edit->Delete Guides ile silinebilir.

Olcii almak i¢in birinci noktaya tiklanir ve ikinci noktada
bekletilir ve deger okunur.

)

Tape Measure ayni zamanda nesnenin yeniden
o6lciilendirmesini de saglayabilir.

Yiizey kenarinda ilk ve ikinci noktaya tiklanilip yeni Length
degeri girilirse varlik bu deger dogrultusunda yeniden
boyutlandirilacaktir.
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Protractor (A1 Olger) Araci

@ Acil kilavuz gizgileri olusturmak i¢in kullanilir.

Arag segcilir ve ilk noktaya ve ikinci
noktaya yandaki gibi tiklanir.

® [ Jfrom P

e Imlec hareket ettirilir ve ac1 degeri
Tk Angle kutusuna girilir.

Diger taraftada ayni islem yapilir.

Bu gizgiler izerinden Line ile
gecilerek yiizey tamamlanir. Aradaki
cizgi istenirse silinebilir

Grup Olusturma Islemi

Bir nesneyi tiim varliklariyla gruplayarak bir araya getirme islemidir. Nesnenin tiim secilir ve izerine sag
tiklanarak Make Group komutu isaretlenir.

- Islem sonras1 Move araciyla nesne iizerine

: fare gotiirildiigiinde nesne iizerinde kirmizi
tutma noktalari belirir. Nesne bu
noktalardan tutularak dondirtilebilir.

Nesne lizerinde Push/Pull vb. Diizenleme islemleri yapilmaya
kalkildiginda bu islemin yapilamayacagini gosteren bir sembol
belirecektir. Objenin diizenlenebilmesi i¢in iizerine ¢ift tiklanabilir veya
lizerine sag tiklanip Edit Group komutu segilebilir.

Bu asamda grubun icine baska bir yerden kopyalanan(kesilen
(copy/cut) nesne veya grup yerlestirilip (paste) onun bir pargasi
yapilabilir.

Nesne etrafinda kesik ¢izgilerden olusan bir ¢ergeve olusacaktir.
Diizenleme modundan ¢ikmak i¢in nesne disinda bir yere tiklanabilir
veya cerceveye sag tiklanip Close Group komutu segilir.

Bir grubu tekrar normal nesne yapmanin yoéntemi tizerine sag tiklayip Explode komutunu se¢mektir.

Telif Hakk: . Copyright © 2010 Salih Ofluoglu - Kaynak gosterilmek suretiyle alint1 yapilabilir \ 2




SKETCHUP DERS NOTLARI — PROF. DR. SALIH OFLUOGLU

ALISTIRMA:

Masa ayagi follow up araciyla kutu
profili icinde dondiriilerek kirpilir.
Ayaklar ve liste gelen tabla grup veya
asagida anlatilacak component
yapilarak calisilir.
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Bilesenlerle (Components) ile Calisma

Sik tekrarlanan nesneleri bilesen olarak kaydetmek ve
gerektiginde geri cagirmak modelleme zamanini 6nemli
Olciide azalacak ve verimliligi arttiracaktir. Sketchup ile
gelen bir takim bilesenler bulunmaktadir. Bunlar1 gérmek
icin Window—>Components secilir. Bu pencerede yandaki
gibi Component Sampler segilir.

Sketchup acilirken bu bilesenleri kurulmus oldugu klasor
altindaki Components klasortinden alir. Bu klasore yeni
bilesenler veya alt klasorler eklenerek program agilirken
bunlarin da agilmasi saglanabilir.

Anlik yerel dosya alimi asagidaki gibi saglanabilir:

. || I Cpen or create a local collection, I
Sawe as a local collection, .,

Diger basliklardaki bilesenler i¢in Sketchup diinyadaki diger
kullanicilar tarafindan beslenen Google 3D Warehouse
merkezi veritabanina basvurur. Bu veritabanindan anahtar
sozclikler arama yapilmak istenirse bu sozciik Google
kutusuna girilerek aratilir.

Ekrana yerlestirilen bilesenler far (In model) diigmesine
basilarak goriintiilenebilir. Bir kez ekrana yerlestirilen
bilesenler ekrandan silinseler de bu listede kalmay1
surdirtrler. Bunlar kaldirmak i¢in asagidaki islemle Purge
Unused segilir.

,0 Open or create a local collection. ..

Save as a local collection.
30 Warehouse Terms of Service

Expand

Purge Unused

Kiitiphanenin ihtiyaca cevap vermedigi bir durumda bir
bilesen de yaratilabilir. Nesne olusturulup secildikten sonra
lizerine sag tiklanip Make Component segilir.

Component ile olusturulan nesnelerden kopyalar
tiretildiginde birinde yapilan degisiklik tiimiinde otomatik
olarak gerceklesir.

Components 5]
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Acilan pencerede Component’e isim verilebilir. Create Component X

General

Set Component Axes diigmesi ile Component’in mevcut

Mame: IPencere
yerlesetirme noktasi degistirilebilir. Component tizerinde

. . . . L iption:
yeni yerlestirme noktasi olacak yere ti¢ defa tiklayarak islem s
tamamlanir. Component tizerinde degisiklik icin tizerine cift
tiklanir ve diizenlem modunda girilir. Bir nesnenyi Aligrrnent:
Glue bo: INone vI Set Companent Axes |
Component olmaktan ¢ikartmak icin iizerine sag tiklanip I™ cut opening

I~ Always Face camera

Explode secilir. Bir Component’in diger kopya I ahodomst

component’lare yapilan degisiklikten etkilenmemesi tizerine
sag tiklanip Make Unique secilerek saglanabilir. ¥ Replace selection with component

Cancel | Create I

Ekranda bir component lizerine sag tiklanarak Save As
secilirse o component baska projelerde kullanilmak tizere
ayr1 bir Sketchup dosyasi olarak kaydedilebilir. Bu dosyadan
yaralanilmak istenirse Components klasoriinde saklanabilir
veya File> Import ile ¢agrilabilir.

[Eudpon]

Ornek:

600;1000 cm o6l¢iilerinde bir Push/Pull araciyla 300 cm Protractor araciyla 18.26
dikdortgen cizilir. 20 cm’lik bir yukseltilir. derecelik (%33) liik iki Guide
offset alinir. izgisi olusturulur.

Bu Guide’lardan gecen iki cizgi Cat1 tiste kismindaki iki ¢izgi Uglardan kapatilarak ytizey
cizilip sekildeki Push/Pull ile itilir.  secilip ve Offset araci ile 20 cm elde edilir.
uzakta parallel kopya ele edilir.
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Push Pull ile yiizey itilir.

Dikdortgen araciyla pencere
olacak kisim meydana getirilir.

Cerceve lizerine saydam ve ahsap
malzeme atanir. Uzerine ii¢ defa
tiklayip tiim sekil secilir ve tizerine
sag tiklanip Make Component
komutu ile bir bilesen olusturulur.

Pencere dis ylizeyden 10 cm
iceride olacak sekilde
yerlestirilmitsir.

Cat1 ve On yiizey arasindaki ¢izgi silinir ve tape measure araciyla
yukaridaki 6lctilerde Guide’lar olusturulur.

5 cm’lik bir ¢cergeve olusturulur.
Ustten ve alttan 2.5 cm
Push/Pull ile uzatilarak 5 cm’lik
bir cerceve meydana getirilir.

Bu alan segilip tizerine detay
eklenmek tizere disariya
kopyalanir.

Daha once ytlizeyde olusturulan
dikdortgenden bir kopya diger
ucta meydana getirilir.

6/ yazarak aralarin 5 kopya ile
dolmasi saglanir. Yiizeylerine
tiklanarak silinir.

Pencere bileseni icine cift
tiklanarak orta kenardan gecen
2 cm’lik kayitlar olusturulur.

Yukarida oldugu gibi pencereden
kopyalar yerlestirilir.
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Yapilan ilem tiim kopya Ara gizgiler silinir. Bu kayit cift tiklanarak grup

componentlere aktarilacaktir.

yapilabilir. Kayit 1.5 cm
Push/Pull ile yiikseltilit ve
malzeme atanir.

Outliner ile Grup ve Bilesenleri Listeleme

Outliner bir modeled yer alan tiim bilesenler ve gruplari ve hatta onlarin alt gruplarini gérmek igin
kullanilir. Windows-> Outliner secilerek ulagilir.

Outliner’daki listeden bilesen ve gruplar gortintiilenebilir.

Filter: | @

[@ Untitled
1= csandalyel>
= <sandalyels
= <sandalyeZ >
m sandalye3
-1~ m sehpa
= m silindir
= <poligon:=

sembolil ile baslayanlar bilesendir. Bunlar arasinda ayni
isimli olanlar birbirine baghdir. Birinde yapilan degisiklik
digerini otomatik olarak etkiler.

sembolii ile baslayanlar ise gruptur.

Modellemede calisma kolaylig1 agisindan saglayabileegi
kolayliklar nedeniyle bir grup veya bilesenin altinda alt
grup ve/veya alt bilesen olabilir.

Buradaki bilesen ve gruplara lizerlerine sag tiklanarak su islemler uygulanabilir:

e Erase, bilesen veya grubu siler.

e Hide, bilesen veya grubu gizler; Unhide, tekrar gortintr hale getirir.
e Lock, bilesen ve grubu degisiklik yapilmamasi i¢in kilitler; Unlock, kilidi agar.
e Edit Group/Component, grup ve bileseni iizerinde degisiklik yapilabilecegi diizenleme moduna

cevirir.

e Make Unique, bileseni kopyalandigi bilesenden ayri1 diizenlenebilmesi i¢in bagimsiz yapar.
e Explode, bilesen veya grubu normal nesneye doniistiiriir.
e Rename, grup veya bilesene yeni isim verdirir.
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Katmanlarla Calismak

Katmanlar ¢izime eklenen bilgileri siniflandirmak ve Layers (=]
gerektiginde saklamak icin kullanilir. @O B
Name | Visible | Color |

Window->Layers veya Layer ara¢ cubugundaki e diigmesine 3 Laverd [ ]
basarak Layer Manager penceresi acilir. Blagaar,

Yeni bir katman yaratmak i¢in ® semboliine basilir. Agaclar
katmani olusturup bu katman iizerine tiklayip etkin hale Components B
B

getirelim. |
@/ ‘

Bu katman etkinken “Component Sampler”dan bir aga¢ (Tree 3D
Evergreen) secip cizime yerlestirelim ve 3x yazip kopyalarini

meydana getirelim. select |edit | statitis |
E~ @ []Cow P B
Banklar katmani olusturup etkin hale getirelim. Agaclar arasina i InModel
bilesenlerden bir bank (Bench) secip yerlestirelim 90 derece oy Components
dondiirerek asagidaki gibi yerlestirelim | MyModels
My Collections
Icerigin simetrik bir kopyasini karsisina yerlestirelim. —

{ v Components Sampler

NOT: Bu islem sirasinda kopyalar kendi katmanini korur. Bir elemanin katmani, tizerine sag tiklandiginda
secilen Entity Info penceresinde goriintiilenebilir.

Bir elemanin katmani degistirmek i¢in elemanin ekranda segilmesi gerekir. Ardindan su iki yéntemden
birisi uygulanabilir:

v 0 -] s@ Entity Info =]
=]

o Laverd 18 Entities

Aager | v |

Layers arag.gubugu katman listesinden bir baska Entity Info kutusunda Layer listesinden baska bir
katmana tiklanilir. Layers ara¢ cubuguna katman adina tiklanir.
View->Toolbars—>Layers yoluyla ulasilir.
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insanlar katmani yaratip, bu katman aktifken
ekrana ¢ok sayida insan (Nancy ve Sang)
yerlestirelim.

Layers (=] Katman igerikleri Visible sekmesi iizerindeki Radyo diigmelerine
® O B basilip goriiniir ve goriinmez hale getirilebilirler.
Name | Visible | Color |

Aktif katman saklanamaz. Once bagka bir katmanin aktif hale
getirilmesi ardindan o katmanin kapatilmasi gerekir.

Layer 0 secilerek yay, offset ve cizgi araci
yardimiyla bir yol yapalim.

Katman tiizerine tiklanip C) diigmesine basilarak
silinebilir. Katman icerigi bos degilse asagidaki
ekran ¢ikar:

B

y
Delete Layers Containing Entities Léj Layers
Mame | Visihle | Color |
Layer(s) to be deleted are not empty. Choose what to do with the
contents. & Layer0 .
e 7 g O Banklar
* Move contents to Default layer 3 Adaclar .
" Move contents to Current layer 3 Insanlar B
(" Delete contents
OK | Cancel |

e Yukarudaki mesajdaki Default layer (varsayilan katman) yazilim fabrika ayarlarinda tanimli olan
Layer 0’dur. Yukarida sunulan birinci se¢enekte icerik bu katmana tasinir.
e Current layer (etkin katman) bu islem yapildiginda etkin olan katmandur. Ikinci secenekte icerik

bu katmana tasinir.
e Uciincii secenekte ise katman icerigi ile birlikte silinir.

Layer Manager penceresinde bulunan bazi secenekler sunlar1 yapar:
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Layers @I Purge herhangi bir sekilde kullanilmamis, ekranda
®e B Select All icerigi olmayan bir katmana siler.

Name | Visible | Caolor | Purge

g | Color by layer Color by layer, katman icerigini renk kismindaki
O Adadar [] rankle eslestirir.

> Insanlar [ ]

10
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