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Konu 01 : Temel Kavramlar ve Photoshop Arayüzü 

Sayısal Grafik Tipleri 

Sayısal grafik konusunda statik resimlerle çalışırken iki temel grafik türü ile karşılaşırız: 

  VEKTÖR GRAFİKLERİ 

Tüm Bilgisayar Destekli Tasarım ve Çizim (CAD) 
yazılımları vektör grafiklerini kullanırlar. 

Vektör ifadesi koordinate düzleminde 
konumları tanımlanıp, yönleri, 
uzunlukları/boyutları girilerek oluşturulan 
matematiksel objeler için kullanılır. Geometri 
tabanlıdır. Objelerin konumları ve diğer 
objelerle düzlemsel yakınlık uzaklık ilişkisi ilgili 
veritabanında tutulur.  

Objeler çizgi, dikdörtgen, daire veya yazı 
biçiminde karşımıza çıkabilir.  

Vektör grafikleri ekran üzerindeki 
çözünürlükten bağımsız olarak ne olursa olsun 
açık ve net biçiminde görünürler. Yapmış 
olduğunuz zoom miktarı ne olursa olsun elde 
etmiş olduğunuz görüntü kalitesinde bir 
değişiklik olmaz. Bu yüzden çözünürlük 
bağımsız grafikler olarak da adlandırılırlar. 

 

 

 

Büyültülmüş vektör grafiği  Büyültülmüş raster grafiği 

Vektör grafikleri taşıma, döndürme ve uzatma vb. düzenleme işlemlerine tabi tutulduklarında dahi görsel 
kalitelerinde herhangi bir kayıp olmaz. Bu işlemler de hızlı bir şekilde gerçekleşir. 

Daha az görsel bilgi ile istenilen sonucun elde edilmesi nedeniyle vektör grafikleri ayrıca daha az yer 
kaplarlar. 

AutoCAD, ArchiCAD ve 3DS Max gibi CAD programlarının hepsi vektör grafikleri ile çalışırlar. 

Bunun yanı sıra ağırlıklı olarak raster grafiklerini kullansa da Photoshop ileride göreceğimiz Path 
oluşturma gibi çeşitli araçlarında vektör grafiklerini de zaman zaman kullanır. 
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RASTER GRAFİKLERİ 

Görüntü ya da resmin noktaların bir araya gelmesi ile oluşturulmasına dayanır. Bir raster resmini 
meydana getiren noktalara piksel (PIXEL: picture elements) adı verilir.  Yazıcılar söz konusu olduğunda 
piksel yerine dot ifadesi de kullanılır. 

Her bir piksel resmin şekli ve rengiyle ilgili bilgiyi 
içerir. Bir araya gelerek resmi oluştururlar. 
Resimlerin içermiş olduğu nokta sayısı değişebilir. 
Çok nokta içeren resimler daha gerçekçidir.  

Raster resimleri  tarayıcı, dijital fotoğraf makinası 
veya web gibi çok farklı platformlardan elde 
edilebilir. Photoshop gibi görüntü işleme 
programları üzerlerinde değişiklikler yapılmasını 
mümkün kılar. 

      
 

Örnek dosya: 01_piksel_biberler.jpg 

Raster Grafiği Temel Özellikleri 

RESİM BOYUTU (image size) 

Piksel, ayrıca bir resmin 
boyutunu göstermek için bir ölçü 
birimidir. Bir resmin ekran 
üzerinde ne kadar yer 
kaplayacağı içerdiği piksel sayısı 
ile doğru orantılıdır. 

Örneğin 640 x 480 piksel 
boyutlarına sahip olan resim 
yatay olarak (satır) 640 piksellik 
ve dikey olarak 480 piksellik yer 
kaplar. 

Örnek dosya: 01_ordek.jpg   

NOT 1: Ruler açıkken pixel ölçü 
birimi sağ tıklayarak seçildiğinde 
resim ölçüleri görülebilir. 
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NOT 2: View Show Grid resim üzerinde gridlerin gözükmesini sağlar. 

Piksel aynı zamanda monitör üzerinde oluşturulacak görüntünün boyutlarını tesbit etmek amacıyla da 
kullanılır. Günümüz ve geçmişten bazı standart görüntü modları (display modes):  

VGA‐Video Graphics Array, 640 x 480 piksel 

SVGA‐Super Video Graphics Array, 800 x 600 piksel  

XGA‐Extended Graphics Array, 1024 x 768 piksel 

SXGA‐Super Extended Graphic Array, 1280 x 1024 piksel 

UXGA Ultra Extended Graphics Array, 1600 x 1200 piksel 

Imaja ait piksel ayarlarına PhotoShop’ta Image Size komutuna Image menüsünden ulaşılır: 

 

Burada yer alan diğer nesneler sırası ile aşağıda ele alınacaktır: 

ÇÖZÜNÜRLÜK/RESOLUSYON (sample rate) 

Bir birim alan içine düşen piksel veya nokta sayısıdır. Genellikle birim alan olarak inch kullanılır. Bir inch 
2.54 cm’ye karşılık gelir. Bir inch içerisine düşen nokta sayısı ne kadar fazla olursa, o kadar kaliteli foto 
gerçekçi sonuçlar elde edilecektir.  

Resolüsyon değerinin değişmesi resmin ekran üzerinde kaplayacağı alanı arttıracaktır. Bu artış biraz 
sonra göreceğimiz çıktı boyutlarını (Document Size) değiştirmeyecektir. 

Bazı çözünürlük birimleri: 

ppi (pixel per inch)  Ekran 
dpi (dot per inch)  Yazıcı
Megapiksel (1 milyon piksel)  Dijital fotoğraf makineleri

Yatay ve dikey piksel değerlerinin 
çarpılmasıyla elde edilir. 
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212x320 piksel 
72 ppi 

Asıl zoom: %100 

 

53x80 piksel 
10 ppi 

Zoom büyültmesi: %700 

 

Asıl zoom: %100 

Örnek resim: 01_piksel_kartal.psd ve 01_piksel_kartal2.psd 

Görüleceği gibi yukarıdaki işlemde eagle2.psd resminin çözünürlük düşürüldüğünde resim kendisini 
anlaşılır bir şekilde ifade edebileceği bir boyuta küçültmektedir. Resim zoom aracıyla ekranda eski 
boyutuna büyültüldüğünde görüntü alanını doldurmak için piksel boyutu arttırılır  ve resim daha bulanık 
(pikselleşmiş) gözükür. Pikseller arası mesafe daha fazla olmaktadır. 

Ne kadar çözünürlüğe ihtiyaç duyacağınız yaptığınız işte elde etmek istenecek sonucun kalitesiyle doğru 
orantılıdır. Web’de sunum ve monitör ekranından sulacak çalışmalar için 72 ppi yeterlidir. Inkjet bir 
yazıcıdan çıktı almak için 240 dpi yeterli olacaktır.  

NOT: Bugün birçok printer da ifade edilen 1440x720 gibi değerler inch başına düşen mürekkep damlasını 
gösterir. Bir piksel’i oluşturmak için birkaç damla mürekkep gerekir. Resim çözünürlüğünü bulmak için 
genellikle yazıcı küçük değeri üçe bölünür. 720/3=240dpi. 

ÇIKTI BOYUTLARI 

Dosyanın print edildiğinde kaplayacağı fiziksel alandır. Hard copy boyutu olarak da adlandırılabilir. Image 
Size penceresinde Document Size olarak yer almaktadır. Piksel boyutları ile belgenin çıktı boyutları 
arasında doğru orantı vardır. Piksel boyutları yüksek olan resmin çıktı boyutu da büyük olur. Örnek: 
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DOSYA (FILE) BOYUTU 

Yukarıda anlatılan hard copy çıktının tersine, dosyanın elektronik depolama birimlerinde ne kadar yer 
kaplayacağını gösterir. KB (kilobyte), MB (Megabyte) ve çok ekstrem durumlarda GB (gigabyte) 
boyutlarında olabilir. 

Dosyanızın ne kadar boyuta sahip olduğunu statü çubuğunun solunda okuyabilirsiniz: 

 

Burada gözüken ilk değer dosyanın tek katmanlı (flattened) halinin dosya boyutunu, sağdaki ikinci değer 
ise dosya katman ve varsa kanallar (channels) içeriyorsa bunları dahil edecek şekildeki dosya boyutunu 
gösterir (Photoshop’un kendi dosya formatı olan .PSD ve bunun dışında TIFF formatı dosyaları bu şekilde 
kaydettirir). 

Özellikle geçmişte depolama medyasının pahalı olduğu dönemlerde dosya boyutu çok küçük tutulmaya 
çalışılırdı. Şimdilerde ise bu kısıtlama büyük ölçide kalkmış durumdadır. Buna rağmen büyük boyutlu 
dosyalarla çalışmanın çalışma hızını yavaşlattığı unutulmamalıdır. 

DOSYA FORMATLARI 

PhotoShop birçok farklı dosya tipi ile çalışma ve kayıt etme imkanı verir. En çok kullanılan dosya 
formatları ya da tipleri aşağıdaki gibidir. 

PSD 

 

Photoshop programının kendi dosya tipidir. Diğer dosya tipleri tarafından 
desteklenmeyen Photoshop’un içermiş olduğu katmanlar gibi ekstra bazı özelliklerin 
kayıt edilmesine imkan verir. Bu nedenle üzerinde emek harcadığınız projelerin bir 
kopyasını bu formatta saklamanız da fayda vardır. Bu sayede tekrar dosyalarınız 
üzerinde çalışma imkanı elde edersiniz. Genellikle dosya boyutu büyüktür. 

TIFF  TIFF grafik sektöründe yaygın olarak kullanılan güçlü bir dosya tipidir. Photoshop’un 
katmanlarını bu dosya tipi ile de kaydetmek mümkündür. En önemli sorunlarından 
birisi yaratmış olduğu yüksek dosya boyutudur. 

JPEG 

 

Bu dosya tipi özellikle Web sayfalarında yaygın olarak kullanılır. En önemli özelliği 
sıkıştırma özelliği ile dosya boyutlarını çok küçültebilmesidir. Sıkıştırma özelliği bir 
dezavantaj olarak resim kalitesinden biraz ödün verilmesine  yol açar. 

GIF  Sadece 256 renk içeren Indexed Color renk modunu destekler. Web’de yaygın 
kullanılır. Bunun dışında küçük resim (Clip‐Art)’larda faydalıdır. Web’de saydam grafik 
yaratmak için de kullanılır. 
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Photoshop’un Arayüzü 

Photoshop Adobe firması tarafından üretilen en yaygın olarak kullanılan görüntü işleme yazılımıdır. 
Sayısal resim dosyaları üzerinde düzenlemeler yapmaya yarar.  

PhotoShop programının arayüzü Toolbox (araç kutusu), Menubar (menü çubuğu), Palettes (paletler) ve 
Options bar (seçenekler çubuğu) elemanlarından oluşur. 

 

 

Toolbox (Araç kutusu): 

Genellikle ekranın sol kısmında yer alan Toolbox (araç kutusu) program içinde yer alan 
seçim yapma, boyama, kırpma vb. daha birçok aracı üzerinde bulundurur. Kapalı olduğu 
durumda Window menü öğesinden Tools seçilerek görünür kılınabilir. 

Toolbox üzerinde yer alan bir aracı seçmek için üzerine tıklamak yeterlidir. Altında küçük 
bir üçgen bulunduran araçlar diğer başka araçları da barındırırlar. Bu tipteki bir aracın 
üzerine tıklandıktan sonra fare basılı tutulursa tüm içerdiği araçlar gözükecektir. 
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NOT 1: Toolbox paletinin altından hızlı bir şekilde ulaşılabilen Image 
Ready Web üzerinde yer alacak grafik dosyaları ile çalışmak amacı ile 
kullanılır. 

NOT 2: Windows   Workspace   Default Workspace programın 
geçerli arayüzüne geri dönmek için kullanılır. 

 

 

Menubar (Menü çubuğu): 

Menü çubuğu, tüm windows programlarında bulunan, çeşitli komutlara ulaşmak için kullanılır. Bir öğenin 
üzerine tıklandığında o öğeye ait alt menü açılacaktır. Üzerlerinde üçgen olan alt menü öğeleri de kendi alt 
menülerine sahiptiler. 

İlgili komuta ulaşıncaya kadar bu oklar fare ile takip edilir. Sırasıyla yer alan menüler şu şekildedir: 

 

File (dosya) menüsü: Genellikle dosya açma, kapama ve kayıt etme ile ilgili komutları 
bulundurur. Burada aynı zamanda dosya import/export etme, programdan çıkma gibi komutlar 
da bulunur. 

Edit (düzenleme)/Image (imaj) menüleri: Bu menüler açılmış bir imaj üzerinde değişiklikler 
yapmaya yarar. Edit menüsünde kesme, yapıştırma, stroke (seçili bir path çevresinde kontur 
çizmeye yarar), boyutsal ve şekilsel transformasyonlar yapan komutlar bulunur. Image 
menüsünde ise renk modu (color mode), canvas (çalışma alanı), imaj boyutu ve global renk 
ayarlamaları yapan komutlar yer alır. 

Layer (katman) menüsü: Katman yaratmak, silmek, birleştirmek, katman efekti uygulmak ve 
gruplamak gibi komutları bulundurur. Bu kontrollerin birçığu ayrıca Layers paletinde de bulunur. 

Select (seçim) menüsü: İmaj üzerinde seçim yapmayla ilgili çeşitli seçenekleri bulundurur. 
Burada seçilmemiş alanı seçili yapmak (invert selection), keskin bir kenarı yumaşatmak (feather), 
seçimi modife edici kontroller (modify), seçimleri kaydetmek ve yüklemek için çeşitli komutlar 
yer alır. 

Filter (filtre) menüsü: Bu alan resimler üzerinde çeşitli etkiler yaratmak için kullanılan 14 
kategoriye ayrılmış Photoshop programına ait 101 filtre bulundurur. Bunun dışında üçüncü parti 
üreticilere ait filtreler de kendi başlıklarında burada sıralanır. 

View (görünüm)/Window (pencere) menüleri: View menüsü zoom ve önizleme yapma, cetvel 
ve kılavuz çizgilerini görünür kılma gibi komutları içerir. Window menüsü 17 paletten her hangi 
birini açmaya ve kapamaya yarar. Aynı zamanda açık olan dosyaları da gösterir. 

Help (yardım) menüsü: Bilinmeyen bir konuyla ilgili yardım almaya yarar.  
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Palettes (Paletler): 

Photoshop istenildiği gibi hareket ettitilebilen paletler vasıtasıyla
bir takım sık kullanılan kontrolleri kolayca ulaşılabilir kılar. 
PhotoShop’ta toplam 17 palet bulunur. Yer kazanmak amacıyla 
istenildiği gibi açılıp, kapatılabilirler. Bu amaçla Window menüsü 
kullanılır. Çalışma alanından tasarruf etmek amacıyla birden fazla 
palet aşağıdaki gibi aynı pencerede gruplanmıştır. İlgili sekmeye 
tıklanarak palet aktif hale getirilir. Bir palet ayrıca seçilip taşınarak 
başka bir palet grubu içine yerleştirilebilir veya boş bir alana 
taşınıp yeni bir palet penceresi yaratılır. 

 

Aşağıdaki gibi palet büyültülüp ve küçültülebilir veya boyutları 
değiştirilebilir. 

NOT:  Photoshop için sağdaki History paleti özellikle önemlidir. 
Photoshop’un “Undo” özelliği sadece bir adım geri alabildiği için 
daha fazla adım geri alabilmek için History paleti kullanılır. Bu 
palet üzerinde açık olan dosya üzerinde gerçekleşen işlemler 
görülebilir. Seçilen adıma tıklandığında bu adım ve sonrasındaki 
işlemler iptal edilir. CTRL+ALT+Z kısayolu ile de history adımları 
geri alınabilir. 

 

 

 

Palet menüsü palet ile ilişkili işlevlere ilişkin 
seçenekleri sunar. Bu işlem için yandaki gibi 
siyah üçgen içine tıklanır ve ilgili seçim 
yapılır. 

 

 

Bir kısım paletin altında da seçilen palet ile 
ilgili komutlara dair kısa yollar bulunur. 
Fareyi üzerlerine bekleterek çıkan bilgiden 
komutların işlevi öğrenilebilir . 

NOT: (Edit>Preferences>General seçilip 
Options kısmında Show Tool Tips seçiliyse 
gözükecektir). 
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Options bar: 

Seçenekler çubuğu Toolbox’ta seçilen bir araç ile ilgili çeşitli özellikleri üzerinde bulundurur. Her aracın 
kendi özelliklerine uygun seçenekler sunar. Kapandığı takdirde Window menüsünden Options seçilerek 
veya Toolbox üzerindeki herhangi bir araç üzerine çift tıklanarak açılabilir. 

 

Cetvel (Ruler), Grid ve Kılavuz Çizgileri (Guide)  

Bu özellikler çalışılan dosya üzerinde gerçekleşecek 
işlemlerin ne kadar büyüklükte (ruler) yer kapladığını 
görerek bölümleme yapmak , çalışma alanındaki öğeleri 
bir hat/çizgi (guide) boyunca veya bir karelaja  (grid) 
göre hizalamak için kullanılırlar. 

Ruler, View>Ruler seçilerek aktif hale getirilir. Açılan 
Ruler üzerine sağ tıklanarak cetvelin ölçü birimi 
değiştirilebilir. 

 
Grid’ler, View > Show > Grid ile görünür yapılabilir. Bu 
gridler üzerinden geçen bir çizim yapabilmek için View > 
Snap seçeneği işaretli olmalıdır. 

Nelere snap olunacağı ise View > Snap to alt 
menüsünden belirlenir. 

 

Kılavuz çizgileri (Guide) cetvel üzerine tıklanıp basılı 
tutulup istenen yönde çekilerek meydana getirilir.  

 

Yerlerinin değişmemesi için kılavuz çizgileri 
View > Lock Guides ile kilitlenebilir. 

 
 

Grid mesafeleri vb. ile ilgili birim değişiklikleri Edit > 
Preferences > Units & Rulers ile gerçekleştirilebilir. 

Kılavuz çizgileri, gridlerin renkleri ise  
Edit > Preferences > Guides, Grid & Slices  
penceresi vasıtasıyla değiştirilebilir.   

 


