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Poligon Modelleme 
Yamalardan (patch) oluşan modellemenin aksine, Poligon modelleme poligonlardan oluşan 
modelleme biçimidir. Poligon düz çizgilerle sınırları tanımlanmış kapalı bir düzlemdir. Nurbs’lerde bu 
kenarlar eğrilerden meydana gelmekteydi.  

 

Poligon ve nurbs modelleme arasındaki farkı anlamak için aşağıdaki küre incelenebilir.  

   
Poligon küre  Nurbs küre 
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Görülebileceği gibi aynı biçimi elde edebilmek için soldaki kürede daha fazla bölümleme çizgisine 
ihtiyaç duyulmaktadır. Soldaki küre sağdaki kadar bölümlemeye ayrıldığında (subdivision axis=8 ve 
subdivision height=4)  elde edilen biçim eğrisellikten uzaklaşıp düzlemsel bir forma dönüşmektedir: 

 

Poligonun Temel Bileşenleri 

1‐Verteks/nokta: Poligonun en küçük birimidir. En 
sık karşılaşılan poligonlar üç noktadan meydana 
gelir. Dört veya daha fazla noktadan meydana gelen 
poligonlar da bulunur.  
 
2‐Kenar: İki noktayı bağlayan çizgilerdir. 
 
3‐Yüz: Poligonun görsel sunumudur. Obje render 
edildiğinde gördüğümüz kısmıdır. Poligonun yüzey 
niteliklerini yansıttığı kısmıdır. 
 

 

Poligonların avantajları: 

Düşük çözünürlüklü‐yüksek çözünürlüklü modelleme: İstenildiğinde düşük çözünürlükle başlayan bir 
modelleme işlemi hızlı şekilrde yüksek çözünürlüklü hale getirilebilir. Bu sayede modelin daha fazla 
detay isteyen kısımlarına istenen hassasiyette detay ilave edilebilir. Model değişken poligon ağı 
yoğunluğunda çalışılarak meydana getirilebilir. Bu çalışma şekline subdivision modelleme adı da 
verilir.  

Bu işlem NURBS’lerde çok zordur. Yüksek çözünürlüklü bir ağ yaratmak için tüm spline ağı üzerinde 
tek tek değişiklik yapmak gerekir. Bu da render işi ve düzenlemeyi zorlaştırır. 
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Poligonların dezavantajları: 

Düzgün ve hassas eğriler: Düzgün eğriler meydana getirmek poligonların en büyük sorunlarıdır. Bu 
eğriler meydana getirilse daha bunları gerektiğinde düzenlemek ciddi bir işlem gerektirir ve buna 
rağmen elde edilen şekil istenen doğruluk ve hassasiyette olamayabilir.  

Poligonları kullanım alanları 

Poligonlar genellikle karmaşık ve doğal organik şekilleri (doğanın meydana getirdiği) meydana 
getirmek için daha uygundur. Doğal şekiller tamamen hatasız ve mükemmel görünümlü değildir. Bu 
alanlar aşağıdaki gibidir: 

• Detaylı yaratık ve karakterler: Farklı çözünürlük modlarında çalışmak mümkündür. Böylece 
çok sayıda detay eklenebilir. 

• Doğal organikler: Tüm bitki tipleri. Poligonlar yapraklar, ağaç budakları, kayalar, dağ, vadiler, 
göller ve ahşap evler, taş duvarlar, çakıl taşı yollar, tomruk kabinler gibi doğal yapılar için çok 
uygundur. Bu şekilde tamamen pürüzsü ve hatasız değildir. İçinde asimetrik oluşumlar, 
aşınmış yüzeyler, kaotik yüzey ve detaylar bulundurur.  

• Lineer modeller: Mobilya, bilgisayar ekipmanı, binalar, caddeler gibi lineer modellerde 
kullanılır. Bu nesneler az sayıda eğri ve çok miktarda düz yüzeyden meydana gelir.  

 
Poligonlar, çok fazla eğriler içeren ve üretiminin de yapılması düşünülen arabalar, karmaşık motorlar, 
mekanik aygıtlar için uygun değildir. Bu endüstriyel ürünler yüksek hassasiyet istemekte ve sonsuz 
çözünürlüğe (sonsuz zoom yapılarak aynı netlikte detayları görmek) sahip olmaktadır. Bu şekilleri 
poligonlarla çizmek aynı hassasiyeti sağlamaz. Özellikle bu ürünlerin üretimi de sürecin bir parçası 
olabileceği için hassasiyet ve doğruluk çok önemlidir. 
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Poligon Oluşturma Yöntemleri 

Maya’da poligon meydana getirmenin iki yolu bulunur: 

1‐Primitifleri kullanmak ve bunlar üzerinde değişiklik yapmak 

Bu alternatifte Create>Polygon Primitives menüsü altında bulunan şekiller ilgili seçenekleri 
ayarlanarak oluşturulurlar. 

2‐Poligon objelerini elle oluşturmak. 

Mesh>Create Polygon Tool seçilir. Tıklanan yerlerde poligon verteksleri oluşur. Bitirmek için Enter 
tuşuna basılabilir. Delete tuşuna basılırsa son verteks silinir. Insert tuşu ise son verteksin yerini 
değiştirmek için kullanılır. Yeni bir poligon yaratmak için Y tuşuna basılır. Bu şekilde yaratılan 
poligonlar aynı düzlemde oluşur (co‐planar).  

 

Gridlere snap yaparak bir pentagon oluştur.  
 

 
Poligona ekleme yapmak: Poligon objesi seçiliyken Edit Mesh>Append to Polygon Tool 
seçilerek poligona ilaveler yapılabilir. Bu pol ekleme yapılacak poligonun üzerine tıklanır, 
poligon çizgisi kalınlaşır. Ekleme yapılacak noktalar eklenir.  

Poligon Düzenleme İşlemleri 

Poligon düzenleme işlemleri tüm obje üzerinde veya bileşenlerine uygulanabilir. Bir poligon modelin 
üzerinde düzenleme amaçlı en sık kullanılan bileşenler Vertex, Edge ve Face’dir. Obje üzerine sağ 
tıklanarak açılan marking menüde bu bileşenlere erişiliğ Move, Rotate ve Scale gibi standart 
transformasyon komutları veya Edit Mesh menüsünden bulunan diğer düzenleme komutları 
uygulanabilir. 
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Vertex move  Edge move  Face move 
 

Obje Yumuşatma Komutları 

SMOOTH 

Mesh>Smooth komutu uygulandığı objenin köşelerini yuvarlama etkisi yaratır. Her uygulandığında 
objenin içerdiği poligon sayısını 2 katına çıkarır. Bu şekilde poligon sayısı arttırılan objeler üzerinde 
bütünü etkileyecek hareket güçleştiği için poligon sayısını makul bir değerde tutmak gereklidir. 

 
     

Width=2 
Height=6 
Depth=2 
Subdivision 
width/height/depth=3 

   

 
BEVEL 

Edit Mesh>Bevel komutu kenar, köşe ve yüzleri yuvarlatmak için kullanılır. Aşağıdaki şekilde kenarlar 
seçilerek Bevel komutu uygulanmış ve kenarlar yuvarlatılmıştır: 
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Obje modunda Channel Box üzerinde PolyBevel1 seçilip Offset değeri ile oynayarak yuvarlanma 
ölçüleri değiştirilebilir.  

 

Bundan daha etkileşimli diğer yöntem ise Attribute Editör’de ilgili kaydıraçlarla oynamaktır. Örneğin 
segment sayısı artılara yuvarlanma katsayısı arttırılabilir. 

 

Aşağıdaki örnekte de aynı yönde bulunan çok sayıda kenar seçilerek komut uygulanmıştır: 
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Vertex üzerine Bevel uygulandığında nokta zerinde üçgen meydana gelir. Attr. Edi. Offset değeri ile 
oynanarak yuvarlama alanın dağılımı düzenlebilir. 

 

Face seçilerek de bevel uygulanabilir: 

 

 

CHAMFER VERTEX 

Edit Mesh>Chamfer  Vertex  komutu  yüzey  üzerinde  yer  alan  ve  ona  komşu  olan  alanları  pahlar. 
Burada bu kısmın silinmesine ilişkin bir seçenek de bulunur. 
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WEDGE FACE 

Edit Mesh>Wedge Face yüzü bir kenar etrafında döndürme imkanı verir. Bu işlem için ilgili yüz ve 
kenar ikisi birden seçilir ve komut o şekilde uygulanır. 

   

Attr. Edit. polyWedgeFace1 seçilerek Wedge Angle ile dönme açısı Divisions ile bölümleme adedi 
değiştirilebilir. 

Detay Ekleme Komutları 

ADD DIVISION 

Zaman zaman poligon objeler üzerinde daha detaylı düzenlemeler gerçekleştirmek için bunları daha 
alt bölümlere ayırmak gerekebilir. Bunun için genellikle yüzler seçilerek kullanılır. Komut 
uygulanmaya deva ettikçe bölümleme sayısı artar. Elde edilecek yüzler triangle (üç kenarlı) veya quad 
(dört kenarlı) olacak şekilde meydana getirilebilir. Komuta Edit Mesh menüsünden erişilir.  
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Komut seçilen kenar üzerine uygulandığında kenarı ikiye ayırır: 

 

 

SPLIT POLIGON TOOL 

Poligon yüzeyi daha fazla kontrollü bir şekilde bölmek için Edit Mesh>Split Polygon Tool kullanılır. Bu 
işlem için poligon obje seçilir. Ayırma işleminin gerçekleşeceği kenar seçilir. Diğer bir başka komşu 
kenara tıklanır ve bu ikinci nokta istenilen yere sürüklenir ve tamamlanır. Delete, Insert gibi komutlar 
burada da geçerlidir. Enter tuşu işlemi bitirir. 

             

CUT FACES TOOL 

Poligon yüzü ayırmanın bir başka yolu Edit Mesh>Cut Faces kullanmaktır. Poligon objesi veya 
yüzünün seçilmesinden sonra komut girilir. Önce kesim işleminin olacağı yere tıklanır sonra etkileşimli 
kesme kılavuzu hareket ettirilir, fare bırakıldığında kılavuz çizgisinin yer aldığı yerden yüzey kesilir. 
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EDGE LOOP 

Daha önce Nurbs modellemede yer alan isoparm ekleme komutuna benzer. Poligon biçimin 
çözünürlüğünü arttırarak istenen bölgelerin daha kolay düzenlenmesini sağlamak için kullanılır. 
Aşağıdaki ayarlarla aşağıdaki silindiri meydana getirelim: 

    

Edit Mesh>Insert Edge Loop Tool tıklanılan yönde ilave bölümleme çizgisi meydana getirir. Dikey 
yönde ekleme yapmak için yatay çizgilere, yatay yönde ekleme yapmak için ise dikey çizgilere tıklama 
yapılır ve çizgi istenen yere taşınıp bırakılır.  

 
 

 
 
Edit Mesh>Offset Edge Loop Tool ise aynı işlemi tıklanan çizginin her iki yönünde de aynı ayna 
bölümleme yaparak gerçekleştirir. 
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POKE FACE  

Edit Mesh>Poke Face komutu seçilen yüzden köşegenler geçirerek dört parçaya böler. Bu şekilde 
detay eklenmek istendiğinde faydalanılır. 

 

Poligon Düzeltme Komutları 

CLEANUP 

Poligon objelerle ilgili olabilecek aynı düzlemde olmayan yüzler (non‐planar faces), sıfır uzunlukta 
kenarlar (zero‐length kenarlar) vb. sorunlar Mesh>Cleanup komutu ile kaldırılabilir.  

REDUCE 

Toplam poligon sayısının çok fazla olduğu durumlarda düzenleme yapmak ve render almak 
zorlaşabilir. Bunun için poligon sayısı Mesh>Reduce komutu ile azaltılabilir. Aşağıdaki şekillerde her 
seferinde poligon sayısı  %50 azaltılarak oluşturulmuştur. 
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Üç ve dört kenarları yüzeyler yaratmak 

 
 

       

Elle çizilen poligonlarda aynı düzlemde olmayan 
bir yüzey yaratıldığında kullanılır. Aynı düzlemde 
olmayan  yüzeylerin  düzgün  bir  şekilde  render 
edilmesini sağlamak için uygulanır. 
 
TRIANGULATE 
 
Mesh>Triangulate  komutu  tüm  seçilen  yüzleri 
üçgenlere  çevirir.  Bu  sayede  tüm  yüzeyler  aynı 
düzleme yerleşir.  
 
QUADRANGULATE 
 
Mesh>Quadrangulate  ile  tekrar  dikdörtgenlerle 
çalışılabilir. Bu seçenek yüz sayısını %50 azaltır 

 
FLIP TRIANGLE EDGE 

Triangulate komutunda kenar  istenilen yönde olmayınca bunun yönü Edit Mesh>Flip Triangle Edge 
ile yönü değiştirilir. Bu komut sınır kenarlarda uygulanamaz. 

Örnek: 
 
1‐Poligon düzlemi (plane) çizin. 
2‐Bu  düzlemin  SubdivisionWidth  ve 
SubdivisionHeight değerlerini 1 yapın. 
3‐Sağ  tıklayıp  işaretleme  menüsünden  Verteks 
bileşenini seçin. 
4‐Düzlemin  sağ  üst  verteksini  seçip Move  aracı 
ile yukarı kaldırın. Sol alt verteksini seçip aşağıya 
hareket  ettirin.  Bu  işlem  aynı  düzlemde 
olmamasını sağlayacaktır. 
5‐Polygons>Triangulate  ile  düzlem  üçgenlere 
ayrılır ve aynı düzleme getirilir. 
6‐Bu ara çizgi  seçilip Edit Polygons>Flip Triangle 
Edge ile ters çevrilebilir. 

 
 

 

 
Düzenleme Komutları 

EXTRUDE 

Edit Mesh>Extrude komutu en sık kullanılan poligon modelleme aracıdır. Seçilen Vertex, Face ve Edge 
bileşenini Move, Rotate ve Scale komutları ile desteklenecek şekilde uzatır veya içer doğru 
çekilmesini sağlar. 
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Edit Mesh komutu uygulanırken aşağıdaki Keep Faces 
Together işaretli olduğunda birden fazla bileşen üzerine bu 
komut uygulandığında extrude elden nesnelerin bir blok 
halinde hareket etmeleri sağlanır. 
 
İşaret kaldırıldığında Extrude işlemi uygulandıktan sonra 
aşağıda olduğu gibi bu bileşenler istenilen şekilde hareket 
ettirilebilir. 
 

 

 

Ayrıca vertex ve face üzerine bu komut uygulanabilir: 



BS501 BİLGİSAYAR DESTEKLİ MODELLEME 
Mimar Sinan Güzel Sanatlar Üniversitesi, Enformatik Bölümü 
Doç. Dr. Salih OFLUOĞLU 
 

17 
 

 
Extrude vertex 
Extrude seçeneklerindeki width ve length 
değerleri bu uzantının boyutunu belirler. 

Extrude edge 

 

COMBINE/SEPARATE 

Mesh>Combine iki ya da daha fazla objeyi tek bir obje haline getirir. Aşağıda yer alan biçimi meydana 
getirelim. Önce küre, sonra silindir meydana getirilir. Küreden bir kopya yapılıp yukarı taşınır. Hepsi 
seçilerek Combine komutuyla birleştirilir. Mesh>Separate komutu ise birleşen objeleri ayırmak için 
kullanılır. 

 

 

 
Küre 

 

Silindir   

 

Oluşan biçime telkafes (wireframe) görüntüleme modunda bakıldığında elde edilen sonucun sadece 
şekillerin birleşimi olduğu, model üzerinde herhangi bir değişiklik gerçekleşmediği görülebilir. 
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BOOLEANS 

Mesh>Booleans menüsü ile ulaşılır. Nurbs modellemede olduğu gibi şekillerden ek şekil elde etmek 
(Union), İki şekil arasındaki farkı bulmak (substraction) veya iki şeklin kesişimini elde etmek için 
kullanılır. Ancak burada Nurbs modellemeden farklı bir şekilde uygulanır. Tüm Booleans komutları 
için iki poligon objesi seçilir ve komut uygulanır. İkiden fazla obje üzerinde uygulanmaz. 

Önceki şekili Separate ile ayıralım ve üç kopya meydana getirelim. 
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NOT: Bu şekilde elde edilen geometriler tırtıklı 
sonuçlar verebilmektedir. Bu durum objeye 
Smooth uygulandığında ortaya çıkar. Boolean 
yüzeyler düzgün birleşmez. Bu durumlarda 
verteksler manual olarak bir araya getirilmelidir. 
Genellikle Merge komutundan faydalanılır. 
 

 

 

Simetri alma ve kopyalama İşlemleri 

MIRROR GEOMETRY 

Poligon objelerinden simetri almak: Mesh>Mirror Geometry komutu seçilen poligondan kopya 
simetrisini almak için kullanılır. Bu komut sadece objeler üzerinde çalışır. Yüz, bölüm (segment) veya 
verteks gibi bileşenlerde çalışmaz. 

 
Birbirine bağlı poligonlar Polygon>Separate komutu 
ile ayrılabilirler. 

Seçenekler düğmesine basarak simetri yönü 
veya orijinal ile birleştirilip 
birleştirilmeyeceğine karar verilir.  
 

 
 

MIRROR CUT 

Mesh>Mirror Cut komutunu kullanmak da mümkündür. Bu komut bir düzlem oluşturarak seçilen 
objeyi bu düzlemin iki yanında oluşturur. 
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Yandaki örnekte düzlemin ekseni belirlendikten sonra 
düzlem için önce  
 

 
 
değerleri girilir. Ardından Move ile hareket ettirilerek 
istenen uzaklığa taşınır.  

NOT: Bu düzlemin daha sonra silinmesi simetri alınan kopyanın da ortadan kalkmasına neden olur. 
Bunun yerine objeler seçilip Edit>Delete by Type>History ile geçmiş silinir ve düzlem ondan sonra 
silinir. 

DUPLICATE FACE 

Bir ya da daha fazla yüz seçiliyken Edit Mesh>Duplicate Face komutunu kullanarak seçilen yüz(ler)in 
kopyası yaratılır.  

 

Poligonlarda boşluk yaratmak ve doldurmak 

Poligonlarda boşluk yaratmanın çeşitli yöntemleri bulunmaktadır. 

Bir  verteksi  ayırmak:  Edit  Polygon>Split  Vertex  komutuyla  seçilen 
vertekse  gelen  kenarlar  için  ayrı  bir  verteks  oluşturur.  Daha  sonra 
boşa  tıklanıp  bu  verteksler  seçilip  hareket  ettirilerek  boşluk 
yaratılabilir. Aşağıdaki örnekte bu verteksler tek tek taşınmıştır. 
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EXTRACT 

Yüz  çıkarmak:  Bir  poligonda  yüz(ler) 
seçilerek  Mesh>Extract  komutu 
uygulandığında  bu  yüzler  poligon 
objesinden  ayrılır.  Bu  komutu  seçenek 
kutusunda  bir  offset  değeri, 
transformasyon  değeri  ve  hareket  yönü 
tanımlanabilir.   

 
MAKE HOLE TOOL 

Poligon  obje  üzerinde  çizilen  veya  ona  projeksiyon  olan  yüzü 
poligon yüzden çıkartmak için kullanılır. Bir yüz üzerinde (live object 
ile) bir poligon Mesh>Create Polygon Tool) yaratılır ve her  iki şekil 
Mesh>Combine  ile  birbirine  bağlanır.  Mesh>Make  Hole  Tool 
komutu  bileşen  modunda  çalıştırılır;  üzerinde  boşluk  açılmak 
istenen  yüz  seçilir  (iki  defa  tıklanarak)  sonra  boşluğu  açacak  yüz 
seçilir; Enter tuşuna basarak işlem bitirilir. Sonuç shading modunda 
gösterilir.   

 

 
FILL HOLE 

Mesh>Fill Hole obje üzerindeki tüm boşlukları doldurur. 
 

 
 

 

 

 

 

 

 

 

 


