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Maya Arayüzü ve Çalışma Mantığı 
 
Maya kendine has bir arayüze sahiptir. Bu arayüze aşina olmak ve programın çalışma mantığını anlamak için bir 
süre tanımakla zaman geçirmek gereklidir. 
 

 
 
NOT: Maya ile birlikte açılan Output Window render edilecek görüntü ile ilgili istatistikleri içerir.  
 

Menüler 
 
Menüler içerdikleri işlevlere göre gruplanmıştır. İçerdikleri alt menüler vasıtasıyla Maya 
komutlarına ulaşma imkanı sağlarlar. Burada yer alan ilk altı menü (File, Edit, Modify, 
Create, Display, Window) dışındaki menü başlıkları menü seti seçim listesinden seçilen 
moda göre değişir. 
 
Bu menülere ayrıca fonksiyon tuşlarından da ulaşılabilir: 
F2: Animasyon  
F3: Polygons 
F4: Surface  
F5: Dynamics 
F6: Rendering 
 
F1 tuşu ise tarayıcıyı çalıştırır. 
 
 
 
 

menüler status line 
(durum satırı) 

shelf (raf)

toolbox  
(araç kutusu) 

quick layout buttons 
(hızlı düzen düğmeleri) 

channel box 
(kanal kutusu) 

layer editor 
(katman editörü) 

workspace 
(çalışma alanı) 

help line 
(yardım satırı) 

command line 
(komut satırı) 

time slider 
(zaman kaydıracı) 

range slider 
(aralık kaydıracı) 
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Seçenekler Düğmesi: 
 
Menülerde yer alan kimi elemanın kendi alt menüsü bulunurken, bazılarının yanında bulunan küçük kutucuk 
ilgili menü elemanına ilişkin seçenekleri gösteren bir iletişim kutusuna ulaşıma imkan verir. 
 

 

 
 

Seçenekler iletişim kutusu 
 

 
Açılan pencerelerde ilgili parametre kutularına yerine yeni değerler girilebilir. Girilen değerler bir dahaki sefer 
için geçerli değerler olarak kalırlar. Seçenekler iletişim kutusundaki değerleri geçerli değerlere döndürmek için 
bu kutudaki Reset Tool komutu kullanılır. 
 
Menü kopartmak:  
 
İstenilen menü, menü üstünde bulunan çift çizgiye tıklanarak bulunduğu yerden kopartılıp ayrı bir panel olarak 
kullanılabilir. Bu panelde klavye kısayolları bulunmaz. 
 
 

  
 

 
 
Menülerde bulunan birçok komut “tool” (araç) ifadesi içermektedir. Bu araçlar seçildiklerinde aktif olarak 
eylemlerini bir kez meydana getirirler. Etkilerinin bir kez daha gerçekleşmesi için seçilmeleri gerekir. 
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NOT: Menülerde bulunan bazı komutlara 
ulaşmanın bir başka yolu kısayol tuşlarına 
tıklamaktadır. Mevcut kısayol tuşları istenirse 
Window> Settings/Preferences>Hotkey Editor 
menüsü ile değiştirilebilir. 
 

 
 

Status Line 
 

 
 
Buradaki düğmeler sabit ve değişmezdirler. Düğmeler işlevlerine göre gruplanmıştır. Soldan sağa bu gruplar şu 
şekildedir: 
 

 
menü seti menüsü

 
dosya düğmeleri

 
(Set selection mask)

 
seçim modu menüsü

seçim maskesi düğmeleri (selection mask*) 

 
snap düğmeleri

 
geçmiş düğmeleri (history)

 
rendering düğmeleri

 
seçim alanı (select field)

 
Bu düğmelerin işlevleriyle ilgili açıklamalar ilgili konuda verilecektir.  
 
NOT: Menü araçları ile ilgili kısa pop‐up ipuçları Window>Settings/Preferences/Preferences ile açılan 
Preference penceresinin solunda yer alan Interface altındaki Help panelinde aşağıdaki ayar yapılarak 
gösterilebilir:  
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*Varlıkları tiplerine göre seçmeyi sağlar. Örnek: Polygon işaretli olduğunda sadece poligon objeler seçilir. 
 
Düğme grupları arasında bulunan ayıraçlar, grupları açmak veya kapamak amacıyla kullanılabilir. 
 

 
kapalı düğme grubu ‐ ortası üçgenli ayıraç 

 
açık düğme grubu – ortası kutulu ayıraç

 
Küçük ok içeren bazı düğmelerin tıklanabilir alt
menüsü bulunur. Bu düğmelerin varlığı imlecin 
şeklinden anlaşılabilir: 
 

 
 

 

Yeni bir Proje Başlatmak 
 

Bir Maya sahnesi ile ilgili işlemler Status satırının 

en solunda yer alan   düğmeleri ile 
yapılabilir. Bu düğmeler yeni sahne yaratmak, 
mevcut sahneyi açmak ve kaydetmek amacıyla 
kullanılır. 
 
Bunlar dışında çalışılan Maya projesi ile ilgili 
işlemler File>Project>New takip edilerek 
gerçekleştirilebilir. Bir Maya projesine başlarken 
ilk yapılması gereken işlem budur. Burada projenin 
kaydedileceği yer ve projeyi meydana getiren 
bileşenlerin yerleri ve isimleri ile ilgili ayarlar 
yapılır. Use Defaults düğmesine tıklandığında bu 
kutular geçerli ayarlar kutulara atanır. 
 

 
 

Attribute Editor / Tool Settings / Channel Box 
 

 
 
Status satırının en sağında yer alan bu düğmeler ekranın sağında yer alan yan panellerin açılması ve kapatılması 
için kullanılırlar. Sürekli görünebilirlerdir ve hiçbir düğme grubuna ait değillerdir. 
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ATTRIBUTE EDITOR
nitelik (attribute) editörünün açılmasını sağlar. 
Seçilen obje ile ilgili tüm niteliklerin 
görüntülenmesini sağlar. 

 
TOOL SETTINGS 
aktif araca ait araç ayarlarının (tool settings) 
açılmasını sağlar. Seçilen araçla ilgili 
düzenlenebilen ayarları gösterir. 

 
CHANNEL BOX 
kanal kutusu ve katman editörünün (channel box / 
layer editor) açılmasını sağlar. Değerleri 
girilebilecek nitelikleri gösterir. 

 

Arayüz Elemanını Kapatmak 
 
Bir arayüz elemanını noktalı çift çizgili kısmına tıklayarak kapatmak mümkündür: 
 

 
 
Kapatılan eleman Status satırı veya Shelf üzerine sağ tıklanarak açılan menüden geri çağrılabilir: 
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Alternatif olarak Display>UI Elements alt menüsünden de eksik eleman 
görünür kılınabilir. Aynı yer istenen arayüz elemanlarını saklamak için de 
kullanılabilir. 
 

 

Shelf Menu 
 
Sık kullanılan sekmelerle ayrılmış geometrik nesne ve komutlara kolay ulaşım sağlar. Tıklanan sekme aktif hale 
geçer ve onun düğmeleri sıralanır. 
 

 
 

Raf menüsünün solunda iki menü düğmesi yer alır:   
 
Üstteki düğme sekmelere açılır menüyle ulaşma 
imkanı verir:   
 

 
 

Üçgen biçimindeki attaki düğme ise raf sekmeleri 
kapatmak, Shelf Editör ‘ünü açmak, raf yaratmak ve 
silmek, özel bir raf yüklemek ve tüm rafları 
kaydetmek için kullanılır (projeye kaydetmek ?). 
 

 
 

yeni bir raf yaratmak 
Raf yaratmak ve silmek için New Shelf komutu seçilir. 
Açılan pencerede yeni raf için bir isim girilir. 
 

 
mevcut bir rafı silmek 
Mevcut bir rafı silmek için Delete Shelf komutu seçilir. 
O anda aktif olan raf silinir. (Geriye alınamaz bir 
komut olduğu için dikkatli kullanılmalıdır?) 
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bir rafa düğme ve menü komutu eklemek 
ikon düğmeleri bir başka rafa orta fare düğmesine 
tıklayıp sürükleyerek eklenebilir. Ctrl tuşu basılıyken 
orta fare tuşu ile taşıma sonucu ilgili öğe kopyalanır. 
Menü komutları ise Ctrl ve Shift tuşlarına basılıp 
üzerlerine tıklanarak rafa eklenebilir. Eklenen ikonlar 
orta fare tuşu ile üzerlerine tıklanıp çöp kutusuna 
doğru sürüklenerek silinebilirler. 
 
rafa ekran düzeni eklemek
Panels>Panel Editor seçilir; burada Layouts düğmesi 
aktifken ilgili ekran düzenine tıklanıp Add to Shelf 
düğmesi seçilirse bu düzen rafa aktarılır.  
 
 

 
 

skriptler eklemek 
Skript eklemek için ise Script editöründen sktiptler 
orta fare düğmesine basılı tutarak rafa aktarılabilirler. 

Script editörüne ekranın sağ alt köşesinden   
simgesi ile veya Window>General Editors>Script 
Editor seçilerek erişilebilir. 
 
Örnek: Script Editor açıkken çalışma ekranında bir 
NURBS küre oluşturun, Scale aracıyla bu küreyi 
deforme edin. Görüleceği gibi her yapılan işlem Script 
Editor’de skript oluşturmaktadır. Tüm scripti seçerek 
orta fare düğmesi ile rafa taşıyın. Skriptin MEL ve 
Phyton olarak kayıt edilip edilmeyeceğini sorar: 
 
MEL: Maya Embedded Language, PERL diline 
benzeyen bir dildir. PTHYTON: C++ sintaksına 
benzeyen obje tabanlı bir dildir. 
 

 
 

 düğmesi ile ekran temizlenebilir. 
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Shelf Editor kullanmak 
Bu editör vasıtasıyla rafların sırası değiştirilebilir, 
sekme ve raflara yeni isimler konabilir, raf ikon 
imajları düzenlenebilir ve raflarla ilgili ayarlar 
değiştirilebilir. 
 
 

 
 
NOT: Her bir raf ayrı bir isimle .mel dosyası olarak kaydedilir. Bu dosyalara  
C.\belgelerim\maya\2008\prefs\shelves klasöründen ulaşılabilir. 
 
 

Channel Box 
 

 
 
 
 
 
 
 

Bir objeye ait veri girilebilir nitelikler (veya kanallar) burada yer alır. Her bir nitelik 
kendiyle ilgili bir değer bulundurur. Bu değerler genellikle sayısaldır; bazı 
durumlarda ise on (açık) veya off (kapalı) parametrelere sahiptir. Değerler ilgili 
kutuya sayı girip Enter tuşuna basılarak aktif yapılır. 
 
Değer değiştirmek için bir başka seçenek ise manipülatörü ve değer değişimini 
kaldırır. Burada hareket sağlamanın bir başka yolu +=, ‐=, *=, /= ifadelerini 
kullanmaktır. +=2 objeyi 2 birim hareket ettirir. 
 
Bir nitelik adı üzerine tıklanarak seçilebilir. Değerlerini aynı anda değiştirmek için 
birden fazla niteliği seçilmesi durumunda tıklama sırasında Ctrl tuşuna ayrıca 
basılır. Fare ile sürükleme yaparak da birden fazla nitelik seçilebilir. 
 

 
 
Değişmesi engellenmek istenen nitelikler seçilip Channels>Lock Selected ile 
kilitlenebilirler. Bu nitelikler gri ile gösterilecektir. Kilidi kaldırmak için kilitli 
olanlar seçilip aynı yerden Unlock Selected komutu işaretlenir. 
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Layer Editor 
 
katman eklemek ve silmek
 
katman editörü (layer editor) sahne elemanlarını 

katmanlara bölmek için kullanılır.   Create a New 
layer düğmesi yeni bir katman yaratır. Her katmanın 
bir ismi, görünüm tipi ve rengi olur. Bir katman Layers 
menüsünden silinebilir. Bir katmanın silinmesi içerdiği 
objelerin silinmesine yol açmaz.  
 
katmana obje eklemek 
Objeleri katmanlara aktarmak için ilgili obje(ler) seçilir 
ve katman adına sağ tıklanarak Add Selected Objects 
öğesi işaretlenir. Yeni objelerin bir katman üzerinde 
meydana gelmesi için Options menüsünde bulunan 
Add New Objects to Current Layer komutu ile eklenir. 
Layers menüsü ayrıca bir katmandaki tüm objeleri 
seçmek (Select objects) ve bunları bu katmandan 
çıkarmak için (Remove Selected Objects) kullanılabilir. 
Seçili olmadıklarında bir katmandaki objeler bu 
katmanın rengini alırlar. 
 
katmandaki objeleri saklamak 
Katman editöründe katman sırasının başındaki sütuna 
tıklanarak bir katman görünür (V) veya görünmez 
kılınabilir. İkinci sütun katmana ilişkin Normal, 
Template ve Reference tiplerini bulundurur. Üçüncü 
sütun ise katmanın rengini tanımlar.  
 
Bir katman adına çift tıklayarak katmanla ilgili 
değişiklikler Edit Layer iletişim kutusu ile yapılabilir. 
Burada katman adı verilebilir ve katmanın içerdiği 
nesneler için Wireframe görüntülerinde kullanılacak 
renk saptanabilir. Bu kısımda verilen renk öncelikli 
renk olur. 
 

 
 
Bu bölümüm altında bulunan ok işaretleri kutunun 
genişleme veya daralmasına neden olur. Bu işlem için her 
seferinde tıklama gerekir. 
 
 
 
 
 
 
 
 
 
Template ve Reference kullanılarak o katmandaki 
nesnelerden başka nesneler oluşturulması için 
faydalanılır. Template wireframe Reference shaded 
görüntü verir. Reference olarak gösterilen öğeler 
üzerine snap yapılabilir. 
 
 

 

Animasyon Kontrolleri 
 
Ekranın altında animasyon oluşturmak için kullanılan çeşitli araçlar bulunur. 
 
Time Slider 
 
Time Slider (zaman kaydıracı) üzerinde tüm animasyon karelerini gösterir.  
 

 
 
Bir kareden diğerine siyak zaman işaretleyicisini sürükleyerek veya zaman kaydıracının sağ tarafına gidilecek 
karenin numarası girilerek ulaşılır. 
 
animasyon kontrolü düğmeleri 



BS502 SANAT ve TASARIMDA BİLGİSAYAR I 
Mimar Sinan Güzel Sanatlar Üniversitesi, Enformatik Bölümü 
Doç. Dr. Salih OFLUOĞLU 
 

 10

 
Animasyon zaman kaydıracının sağında bulunan düğmeler animasyonu çalıştırmaya, kareler veya anahtarlar 
arasında geçiş yaptırır. 
 

 
 
Range Slider 
 
Zaman kaydıracının altında bulunan Aralık kaydıracı (range slider) belirli animasyon kare aralığında 
odaklanmaya imkan verir.  
 

 
 
animasyon tercihleri 

Animasyon tercihlerine en son kareye git düğmesinin altında bulunan   simgesine tıklanarak  
ulaşılabilir. Bu iletişim kutusu aynı zamanda Maya ile ilgili tüm tercihleri de barındırır. Timeline kategorisi 
animasyonla ilgili kontrollerde değişiklik yaptırır: 
 

 
 
 

Command Line 
 
Yazılı komutların girilmesi için kullanılır. Tüm komutların noktalı virgülle bitmesi gerekir. Komutların sonucu 

sağda koyu renkli Sonuçları Satırı’nda (Results Line)’da görünür. Bu satırın sağındaki   düğmesine tıklanarak 
daha detaylı skriptlerin yazılabildiği Script Editor’üne erişilebilir. Komut satırına girilen tüm komutlar yukarı ve 
aşağı düğmelerine tıklanarak yeniden çağrılabilir. Büyük küçük harf duyarlıdır (Case Sensitive). 
 

 
 
 
MEL ile taşıma: 

1‐ Create > Polygon primitives > sphere ile bir küre yarat 
2‐ Yaratılan objeyi seçimden çıkarmak için boşa tıkla 
3‐ select pSphere; Enter 
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4‐ move –z 10 
 

MEL ile isim değiştirme: 
rename “pCube4” “kutu”; 
 

Help Line 
 
Arayüzün en altında yer alan bu satır seçilen araç veya modda gerçekleşmesi beklenen talimatlarla ilgili bilgiyi 
gösterir. Sonraki adım için yol göstericidir. 
 

 
 

Toolbox 
 
Ekranın sol kısmında yer alan bu araçlar obje seçmek ve üzerlerinde çeşitli transformasyon işlemleri yapmak için 
kullanılır. 
 

 

Seçim (select) aracı (Select tool) Q  

 

Lasso seçim aracı  

 

Taşı (move) aracı W  

 

Döndür (rotate) aracı E  

 

Yeni boyut (scale) aracı R  

 

Evrensel değiştirici (universal manipulator)
move, rotate , scale özelliklerinin hepsini üzerinde 
birleştirir. 

 

 

Yumuşak değişim (soft modification) aracı  

 

Değiştiriciyi göster (show modificator) aracı 
Seçilen araç için hareket edilecek eksen veya 
yakalanabilecek değiştiricileri gösterir. 
(örnek: create>lights  veya camera 

T  

 

Son kullanılan araç (program ilk açıldığında boştur) 
tekrar boş yapmak için k tuşuna (küçük k) ve seçim 
aracına tıklanır. Menüden seçilen araç 
kullanıldığında aktif olur. Araç kutusundaki araçlar 
üzerinde değişiklik yapmaz. 

Y  

 
 
NOT: Yumuşak değişim aracını kullanmak 
Bu araç tanımlanan falloff radius ve curve ile seçilen objenin yüzeyini deforme eder. İlgili ayarlar araç üzerine 
çift tıklanarak açılır.  
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falloff curve üzerine tıklanarak ilave noktalar 
yaratılabilir. yaratılan ekstra noktaların altındaki 
kutulara tıklanıp seçilerek silinmeleri sağlanır. 
 
Bu araçla tıklanan yüzey üzerine s harfi belirir. 
Değiştiriciler kullanarak şekil deforme edilebilir. 
Değişim merkezinin yeri ve değerleri değiştirilerek bu 
işlem tekrarlanabilir. 

 

 
 
 

 
 

Quick Layout Buttons 
 
Ekranda yer alan görünüm biçimi ve görünüm panel sayısı ile ilgili düzenlemeler yapmak için kullanılır. Araç 
Kutusu’nun hemen altında yer alır. Geçerli görünüm düzenleri aşağıda belirtilmiştir: 
 
 

 

tek perspektif görünümü 

 

dörtlü görünüm

 

perspektif/outliner 

 

perspektif/graph editörü 

 

hypershade/perspektif 

 

perspektif/hypergraph/graph editörü

 

düzen menüsü (ekrandaki görünüm paneli sayısı kadar ok bulunur). Ok sembolize ettiği paneldeki 
görünüm şeklinin açılır menüsü ile değişmesini sağlar: 
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Görünüm Panellerini Düzenlemek 
 
Görünüm paneli çalışmalarımızın birçoğunu gerçekleştirdiğimiz arayüzün ortasında, sahnedeki objeleri gösteren 
geniş alandır. Ekran geçerli olarak dört görünüm panelinden meydana gelmiştir. Görünüm panelindeki objeler 
onlara yöneltilmiş gizli bir kamera ile görüntülenirler. Bu kameralar Outliner ile görüntülenebilir: 
 

 

 
Boşluk tuşu (spacebar) basılarak ekrandaki görünüm panellerinden seçilen biri tek panel olarak ekranı 
kaplatılabilir. Spacebar tuşuna bir kez daha basıldığında bir önceki panel görünümüne geri dönülür. 
 
Görünüm panellerini ayıran çizgilere imleç götürüldüğünde iki yöne bakan ok işareti çıkması beklenir; 

   bu işaret ile tıklanıp sürüklenerek istenen panel genişletilebilir veya daraltılabilir. 
 

 

İlgili çerçevedeki görünümü değiştirmek için soldaki gibi bu oklara tıklanabilir.
 
Her  bir  görünüm  paneli  ekrandaki  görüntü  ile  ilgili  kontroller  içeren  kendi 
menüsünü  de  bulundurur.  Burada  bulunan  Panels  menüsünden  o  panel  için 
ortografik veya perspektif görünümler elde edilebilir. Panellerde sahne objelerine 
ait  geometriler  dışında  başka  panellerde  açmak mümkündür.  Bu  paneller  farklı 
obje seçim yöntemleri, görüntüleri, web tarayıcıları ve editörlerin açılmasına imkan 
verirler. 
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Ekranın kaç panele ve nasıl bölüneceği quick layout 
düğmelerinden herhangi birine sağ tıklanarak da 
belirlenilebilir. Burada oluşturulacak panel sayısı 
belirlenir. Sonrasında hangi panelde ne tür bir 
görünüm olacağı en solda olduğu gibi açılır menüden 
belirlenir.  

 
 
Bunlar dışındaki seçenekler için ise aşağıdaki 
anlatılacak işlemler takip edilebilir: 
 
Panels>Saved Layouts>Edit Layouts veya Panels 
menüsünden Panel Editor ’e tıklanarak seçilerek 
açılan iletişim kutusunda mevcut düzenler 
değiştirilebilir ve yeni düzenler yaratılabilir: 
 

 
Paneli kopartmak 
 
Paneli bulunduğu yerden ayırmak da 
mümkündür. Bunun  için Panels>Tear 
Off komutuna tıklanır. 
Panelin  koparıldığı  yerde  başka  tip 
paneller  açılır.  Panelin  bir  kopyasını 
kopartmak  için  ise  Panels>Tear  Off 
Copy komutu seçilir. 
 

 
İlave panel bilgilerini görüntülemek 
 
Panelde  ilave  bir  takım  bilgiler  görüntülenmek 
istenirse  Display>Heads‐Up  menüsü  seçilebilir. 
Burada  aktif  ekran  üzerinde  görüntülenecek  bilgiler 
belirlenir. Mevcut seçenekler şu şekildedir: 
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Görünüm Panelinde Hareket Etmek 
 
Ekran üzerinde objelere farklı şekillerde bakmak, öteleme (pan) işlemi ile ekranda yer açmak ve yaklaşma işlemi 
için klavyede Alt tuşu ve mouse düğmelerine tıklayarak gerçekleşir. 
 

 
Döndürme işlemi: 
 

Alt + sol düğme tıklaması

 
Öteleme işlemi:  
 

Alt + orta düğme
Tıklaması 

 
Zoom işlemi:  Alt + sağ düğme

Tıklaması 
 
Veya Mouse orta düğmesi bilyesi ileri ve geri 
hareket ettirilir. 

 
Zoom işlemi mouse bilyesi hareket ettirilerek de gerçekleştirilebilir. Bunun dışında bir ekran üzerindeki belirli 
bir bölgeye zoom yapılmak istenirse Ctrl+Alt tuşlarına basılıp yakınlaştırılacak bölge üzerine soldan başlayarak 
bir çerçeve çizilir. Bu çerçeve sağdan başlayarak çizilirse objeden uzaklaşılır. 
 

       
 

Bu  araçlara  ilgili  panelde  View>Camera  Tools  altından  da  ulaşılabilir.  Bu  alt menü  de  aşağıdaki  araçlar  da 
bulunur: 
 

Roll  Görünüm  düzelim  yatay  açısını 
değiştirir. 

Azimuth Elevation Kamerayı  yatay  düzleme  göre 
yükseltir veya alçaltır. 

Yaw‐Pitch  Döndür aracı gibi kamerayı hareket 
ettirmek  yerine,  tüm  sahneyi 
döndürür. 

Fly  Tüm  sahneyi  serbestçe  döndürür. 
Ctrl  tuşuna  basılarak  objelere 
yaklaşılıp, uzaklaşılabilir. 

 
Bu işlemler sırasında 3D ortamında kaybolmak mümkündür. Bu durumda iki işlem yapılabilir: 
 
View>Previous View  
 

Bir önceki konuma döndürür. Kısaltması [ tuşudur.
Bir sonraki konuma bir altındaki seçeneğe tıklanarak veya ] tuşu ile ulaşılabilir. 

View>Default Home  Panelin geçerli görüntüsünü ekrana çıkartır.
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İlave olarak View Cube kullanarak da geçerli konuma 
dönmek  veya  görünüm  panelleri  için  bakış  yönleri 
meydana getirilebilir.  
 
 
 
Bu araç kapalı olduğunda 
Windows>Settings/Preferences>Preferences 
seçilebilir: 
   
 

 
 
 
Objeye odaklanmak 
 
Ekrandaki tüm objelere veya seçili objelere ekranda odaklanmak için View>Frame All (a) veya Frame Selected 
(f) komutu kullanılır. Aynı anda tüm panellerdeki objelerin ekranda odaklanması için Shift+A veya seçili olanlara 
odaklanmak için Shift+F kombinasyonu kullanılır. 
 
Görüntülere ulaşmak 
 
Bir  önceki  veya  geçerli  görüntüye  ulaşmaya  yukarıda  değinilmişti.  Bunun  dışında  bir  görüntü  daha  sonra 
ulaşılmak üzere  favorilere eklenebilir. Bunun  için View>Bookmarks>Edit Bookmarks seçilir. Açılan pencerede 
yeni favoriler eklenebilir ve eskiler düzenlenebilir. View altında bulunan Predefined Bookmarks ayrıca geçerli bir 
takım favoriler bulundurur (perspektive, top, font vb.) 
 

Marking Menu 
 
Gizli menüler birçok komuta hızlı bir şekilde ulaşma yöntemidir. Fare ile görünüm paneline sağ tıklanıp fare bir 
süre basılı tutulduğunda belirirler. İstenen menü işaret edilip komuta erişilebilir. Altta poligon bir çizgi üzerine 
sağ tıklandığında açılan menü gözükmektedir 
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Bu menülerin içeriği istenirse özelleştirilebilir. Bunun için Window>Settings/Preferences>Marking Menu Editor 
kullanılır. 
 

 
 

Hotbox 
 
Maya’da yer alan tüm menülere boşluk tuşuna basarak erişilir. Burada Hotbox Controls seçilerek hangi menü 
setlerinin Hotbox’a dahil edileceği belirlenebilir. 
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Obje Görünüm Modları 
 
Bu panelde gösterilen objeler telkafes (wireframe), renklendirilmiş (shaded) ve dokulu (textured) olarak 
görüntülenebilir. Objelerin görüntülenme kaliteleri de ayarlanabilir. Düşük kaliteli çalışma ekranın güncellenme 
hızını arttıracaktır.  
 
Objelerin renklendirme (shading) biçimini değiştirmek 
 
Objelerin shading tipi görünüm panelindeki Shading menüsü veya klavye kısa yolları ile değiştirilebilir. 
 
telkafes görünüm 
(wireframe) 

objeleri  çizgilerle  temsil 
eder 

klavyede 4
shading>wireframe 
 

yumuşak renklendirme 
(smooth shade all) 
(smooth shade all selected: 
sadece seçilienleri kaplar) 

objelerin  üzerini 
yumuşak  eğrisel  bir 
kaplama ile kaplar 

klavyede 5
shading>smooth  shade 
all  
 

Dokulu (textured) 
 
 

objeleri  üzerine  atanmış 
olan dokularıyla gösterir. 

klavyede 6
 

düz renklendirme 
(flat shade all) 
(flat  shade  all  selected:  sadece 
seçilieleri kaplar) 

objelerin  üzerini  daha 
düz  yüzeylerle  kaplar. 
Görüntü  bir  önceki 
seçenek  kadar  pürüzsüz 

shading>flat shade all 
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değildir 
 
Yine burada bulunan Bounding Box objeleri bloklar, Points ise noktalar ile ifade eder. 
 

 

Renklendirilen bir obje üzerinden  telkafes  çizgilerinin  kalkması  için Shading>Wireframe on 
shaded Obje seçili olduğunda yine bu çizgiler gözükecektir. 
 
Xray seçeneği tüm objeleri yarı saydam yapar. 
 
Transparency Sorting ise objeleri saydamlık değerlerine göre görüntüler. 

 
Shading>Hardware Texturing (veya klavyede 6) objeleri dokulu olarak gösterir. 
 
Shading>Backface Culling  
 
Shading>Smooth Wireframe seçeneği telkafes çizgileri çok daha yumuşak yapar ve tırtıklı görüntüyü önler. 
 
Sadece seçili objeleri gizlemek ve görüntülemek 
 
Birinci yöntemde Show>Isolate Select>View Selected  ile sadece seçili objeler görüntülenir. Bu komuta tekrar 
tıklanarak  diğer  objelerin  tekrar  görüntülenmesi  sağlanır.  Bu  şekilde  çalışırken  görünüm  panelinde  görüntü 
adının başında Isolate ifadesi yer alır. Show menüsünde tüm objelerde saklanabilirler. 
 
İkinci yöntemde Display>Hide>Hide Selected kullanılır. Burada aynıca seçilmeyeni (unselected), tümünü (hide 
all) veya belirli tür spesifik geometrileri saklama seçenekleri bulunur. 
 
Nurbs objelerin çözünürlüklerini değiştirmek 
 
Ekrandaki  objeler  farklı  kalitede  görüntülenebilirler.  Düşük  çözünürlükte  görüntülenen  objeler  daha  kısa 
zamanda güncellenirler, gerçek zamanlı hareket edebilirler. Bu  işlem Nurbs objeler üzerinde çalışır  (aşağıdaki 
örnek  için  Create>Nurbs  Primitives>Torus  kullanıldı).  Farklı  çözünürlükte  çalışmak  için  klavyede  1,2  ve  3 
tuşlarına basılır. 
 

     
 

   
düşük çözünürlük

klavyede (1) 
orta çözünürlük
klavyede (2) 

iyi çözünürlük 
klavyede (3) 
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Transformasyon-Biçimlendirme 
İşlemleri 

 
Bu işlemlerin uygulanabilmesi için öncelikle ekrandaki nesnelerin seçilmesi gerekir. 
 

Seçim Yapmak 
 
Objelerin üzerlerinde çalışabilmek için seçilmeleri gerekir. Bunun için çeşitli yöntemler bulunur. En kolay 

yöntem   seçim aracının kullanmaktir Seçilecek objeler üzerine (birden fazla ise Shift tuşu basılıyken) tıklanır 
veya objelere değecek şekilde bir çerçeve çizilir. Seçimden bir eleman çıkartmak için üzerine Shift veya Ctrl tuşu 

basılıyken tıklanabilir. Bir başka yöntem   Lasso aracı ile seçime girecek objelere değecek şekilde serbest 
formada bir alan meydana getirmektir. 
 
Birden fazla obje seçerken seçime giren son objenin rengi açık yeşil öncekiler ise beyaz olur. Bu yeşil objeye 
anahtar obje adı verilir. Birçok araç bu objeyi işlemlerinde referans alırlar. Örneğin birden fazla eleman hareket 
ettirilirken bu anahtar objenin pivot noktası kullanılır. 
 
Seçim maskelerini kullanmak 
 
Ekranda birden farklı çeşitte obje tipi olduğunda, seçilecek obje tipinin sınırlamak için bir maske uygulanabilir. 
Bu şekilde kullanılabilecek seçim maskeleri aşağıdadır. Bileşen modunda çalışırken kullanılan maske tipleri 
değişir. 
 

 
ÖRNEK:  SEÇİM MASKELERİYLE SEÇİM YAPMAK 
 
Ekrana bir eğri ve bir yüzey çizin ve farklı seçim modlarında seçimler yapın. 
 
 
Seçim Seti yaratmak 
 
Bir seçimi kaydetmek Create>Sets>Set menüsü seçildiğinde set otomatik olarak yaratılır.  
 
Alternatif olarak Create>Sets>Quick Select Set seçilerek seçimler bir isimle kaydedilebilir. Bu seçimlere daha 
sonra Edit>Quick Select Sets ‘den ulaşılabilir.  
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Her iki durumda da seçim setleri adlarına Outliner’dan ulaşılabilir. Set adı seçilip üzerine sağ tıklanıp Select 
Selection Members ile seçim seti öğeleri ekranda seçilebilir. Burada setlerin adı değiştirilebilir. 
 

Alternatif olarak ekranın en sağı yakınlarındaki   Select by name seçeneği kullanılarak 
set adı yazılarak set öğeleri seçilebilir.   
 
Daha sonra çizilen bir nesne Outliner’da orta fare tuşu ile sürüklenip ilgili set üzerine bırakılarak o setin bir 
parçası haline getirilebilir. 
 
NOT: Set adı kelimeler arasında boşluk olacak şekilde kaydedildiğinde set adı boşluk için _ konularak meydana 
getirilir. 
 

Object-Component Modları 
 
Maya’da nesneler tüm olarak (obje modu) veya bileşenlerinden (component modu) seçilebilirler. 
 

Status satırında   Select by Component düğmesine tıklandığında, F8 tuşuna basıldığında veya obje üzerine 
sağ tıklanıp nesnenin hangi bileşeni seçilecese bu işaretlenerek devreye sokulur. Tekrar Obje modu ve bileşen 

modu arasında geçiş yapmak için F8 tuşuna basılır. Satus satırındaki   simgesine basılarak da Obje moduna 
ulaşılabilir. 
 
Bileşenler genellikle vertices (vertekslar), çizgi ve yüzlerden meydana gelir. Bileşen tipi şekilleri objeler arasında 
farklılık gösterir. Bileşenler üzerinde değişiklik yapmak için bu modda olmak gerekir. Bileşen modunda bir obje 
üzerinde sağ tıklayarak farklı bileşen tiplerinin görüntülenmesi sağlanır. 
 

 

Bileşenler objelerle aynı şekilde seçilebilir. Seçili olan bileşenler sarı 
seçilemeyenler ise magenta renginde olur.  
 

 
 
Edit>Paint Selection aracı ile seçim bir fırça yardımı ile obje yüzeyi 
üzerinden geçilerek oluşturulur. 
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ÖRNEK: SEÇİM SETLERİ YARATMAK VE BİLEŞEN MODUNDA ÇALIŞMAK 
 
1‐DonutKutusu.mb ismli dosyayı açınız. 
 
2‐Seçim Aracı ile Shift düğmesi seçiliyken tüm objeleri seçin. Görüleceği gibi son seçilen obje dışında (yeşildir) 
diğerleri beyaz renktedir. 
 

 
 
3‐Seçimi keydetmek için Create>Sets>Quick Set komutunu seçin ve isim olarak donut ifadesini kullanınız. 
 
4‐Boşa tıklayın ve bu kez Lass aracı ile ortadaki ikin donut’ı içine alan bir seçim yapın. 
 

   
 
5‐Shift veya Ctrl basılıyken alt zemine tıklanırda bu alan seçimden çıkartılır. Üstte sağda yer alıyor. 
 
6‐Bileşen (component) moduna geçin. F8 
 
7‐Shift basılıyken donut merkezindeki CV’ler seçilir. Seçilenler sarı ile gösteriliriler. 
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Obje adı ve rengini değiştirmek 
 

 

Obje(ler) seçilir. Objeleri tanımaya yardımcı olmak için Channel Box 
kullanılarak burada en üstünde bulunan kutuya isim girerek objeler 
adlandırılabilir. Bu isim objeyi Outliner veya Hypergraph’da tanımak için 
kullanılabilir. 
 

 
Objenin telkafes rengi Display>Wireframe color ’dan değiştirilebilir. Bunun için nesnenin seçilmesi ve Apply 
düğmesine basılması gerekir. Pencere açık kalarak renk uygulaması sürdürülür.  
 

  
 
 
NOT: Bu paletteki renkler Window > Settings/Preferences > Color Settings altında bulunan User Defined 
kısmından belirlenir. Geçerli nesne wireframe rengi Window > Settings/Preferences > Color Settings altında 
Inactive sekmesinden düzenlenir. 
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Manipulators (değiştiriciler) 
 

 

Taşı, döndür ve yeni boyut araçları seçilen objelerin konumu ve büyükleri üzerinde 
değişiklik yapmaya yarar. Transformasyon bir eksen üzerinde gerçekleştirmeyi 
kolaylaştırmak için her bir değiştirici bir renk ile temsil edilmiştir: X ekseni için 
kırmızı, Y ekseni için yeşil ve Z ekseni için mavi kullanılmıştır. Seçilen eksenin rengi 
aktif olduğunu göstermek için sarıya dönüşecektir.  
 
 
 

 
Seçilen objenin merkezinde (pivot noktası) bir değiştirici (manipulator) yer alır. Bu değiştiriciler transformasyon 
işlemine kılavuzluk eder. Pivot noktası Insert kuşuna basılarak başka bir yere taşınabilir. Bu sayede bir obje bu 
tutma noktasından başka bir objeye kenetlenebilir. 
 

   

Move manipulator Rotate manipulator Scale manipulator 
 
 
NOT: Maya’da yukarı eksen Y eksenidir. Bazı programlarda bu eksen Z’dir. İstendiği takdirde yukarı ekseni 
Window>Settings/Preferences>Preferences ile değiştirilebilir. 
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ÖRNEK: PİVOT NOKTASINI TAŞIMAK 
 
1‐DunyaAy.mb dosyasını açın. 
 
2‐Küçük küreye (ay) tıklayıp seçin 
 
3‐Rotate aracına tıklayın, yeşil değiştici ile ay objesini kendi çevresinde döndürün. 
 
4‐Move aracına basıp, Insert tuşuna aktif yaparak, pivot noktası moduna girin. Kırmızı X ekseni değiştiricisini 
büyük kürenin merkezine taşıyın ve Insert tuşuna bir kez daha bazıp bu pivot modundan çıkın. 
 
5‐Tekrar Rotate aracı ile küçük objeyi Y ekseninde döndürün. Göreceğiniz gibi ay bu kez dünya çevresinde 
dönmektedir. 
 

Transformasyon ve Biçimlendirme İşlemleri 
 
Objenin hareketi pivot noktasından gerçekleşir. Geçerli olarak bu nokta objenin merkezindedir. Insert tuşuna 
basarak pivot düzenleme moduna girilir. Taşı, Döndür gibi araçlarla bu nokta başka bir yere taşınabilir. Tekrar 
Inert tuşuna basarak bu modddan çıkılır. Pivot noktasını tekrar merkeze taşımak için Modify>Center Point 
komutu seçilir. 
 
 

      
 

NOT: Bu işlemi yaparken pivotu nesnenin bir noktasına taşımak için aşağıda anlatılacak snap seçeneklerinden 

 kullanılabilir. 
 

Objeyi bir eksen yönünde hareket ettirmek 
 
Araç kutusunda bulunan Move, Rotate ve Scale araçları ile objeler değişikliğe uğratılır. Bu araçlar seçildiğinde 
bir değiştirici (manipulator) belirir. Bu değiştirici üzerindeki her hangi bir eksen üzerine tıklandığında bu eksen 
sarıya döner ve transformasyonun bu eksen üzerinde gerçekleşmesini sağlar. Mouse orta düğmesine basılarak 
transformasyon tüm eksenlerde gerçekleşir. 
 
Hareketi bir düzlem üzerinde gerçekleştirmek 
 

 

Trasformasyon düzlemi Top veya Front gibi ortografik görünülerde gerçekleştirildiğinde 
bir düzleme kilitlenir. Perspektif görünümde bu işlem Ctrl tuşu basılı tutularak ilgili 
eksen okuna tıklanıp, bu eksen kilitlenerek gerçekleştirilir. 
 
Yandaki örnekte Y ekseni kilitlenmiş ve hareket X ve Z ekranlarında gerçekleştirilmiştir. 

 
NOT: Toolbox’daki tüm araçların ayarına üzerlerine çift tıklanarak ulaşılabilir. Alternatif olarak Status satırının 
sağında sondaki Show Tool Settings düğmesine tıklanabilir. 
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ÖRNEK: TRANSFORMASYON KOMUTLARIYLA ÇALIŞMAK 
 
1‐ArabaTekerlegi.mb dosyasını açınız. 
 
2‐Tekerlekleri Top görünümde seçip x ekseninde 90 derece döndürün. 
 
3‐Move komutuyla yerlerine yerleştirin. 
 
Objeleri ölçekli hareket ettirmek 
 
Ekranın sağında yer alan transform düğmeleri nesneleri ölçekli bir şekilde hareket etmek için kullanılabilir. 
 
ABSOLUTE TRANSFORM:  Objeleri 0,0,0 mutlak orijin noktasına göre konumlandırır. 
 

 

 

 
 
Channel Box’ta bulunan transform düğmeleri 
absolute transform değerleri girerler. 
 
 
RELATIVE TRANSFORM: Bulunulan noktayı orijin kabul ederek hareketi bu noktadan gerçekleştirir. Okların 
gösterdiği yön eksenlerin pozitif olduğu taraflardır. 
 
 

 
 

X=7 
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NOT: Ekranda grafik olarak oluşturulan nesnelerin gerçek boyutları daha sonra Channel Box’ta aşağıdaki kutuya 
değer girerek yeniden düzenlenebilir: 
 

 
 
Transformasyon yaparak kopyalamak 
 
Birkaç objeyi hassas bir şekilde konumlandırmanın bir başka yolu Edit>Duplicate with Transform ‘u 
kullanmaktır. Bu komuta Shift+D ile de ulaşılabilir. Objeden yaratılan kopyanın daha sonra seçilen bir transform 
aracı ile yeri değiştirilebilir. 
 
NOT: Edit>Duplicate (Ctrl+D) ile bir objenin kopyası yaratıldığında yeni obje diğerinin üzerinde yer alacağı için 
seçimi daha zor olacaktır. 
 
NOT: Maya’da aynı komu g tuşuna basarak tekrarlanabilir 
 
ÖRNEK: DUPLICATE WITH TRANSFORM 
 
1‐merdivenler.mb dosyasını açın. 
 
2‐Bir basamağı seçin. 
 
3‐Status satırından “snap to grid” düğmesine tıklayın. 
 
4‐Edit>Duplicate komutu ile basamağın kopyasını oluşturun.  
 
5‐Move aracı ile obje Front panelinde Y (yukarı) ekseninde hareket ettirilir. 
 
6‐Yine Move aracı ile Side panelinde Z ekseninde (sola) hareket ettirilir. 
 
7‐Kopyalanan basamak seçiliyken Edit>Duplicate with Transform seçildiğinde hareket tekrarlanarak aşağıdaki 
şekil oluşur. 
 

 
 

 
 
 
 



BS502 SANAT ve TASARIMDA BİLGİSAYAR I 
Mimar Sinan Güzel Sanatlar Üniversitesi, Enformatik Bölümü 
Doç. Dr. Salih OFLUOĞLU 
 

 28

Obje Gruplamak 
 
Üzerlerinde işlem yapmak amacıyla objeleri 
gruplamak için Edit menüsünden Group komutu 
kullanılır. Seçilmiş objeler gruplanır. Grup ve içeriği 
seçilebilir bir nod olarak Outliner ‘da görünür. Gruplar 
Edit>Ungroup komutu ile tekrar çözülebilirler. 
 

 
 

Ebeveyn Obje Yaratmak 
 
Objeleri biraraya getirmenin bir başka yolu bir objeyi diğerinin ebeveyni yapmaktır. Ebeveyn objedeki değişiklik 
yavru objeleri etkiler. Ancak yavru objeler ebeveyn objelerden bağımsız hareket edebilirler. Bu tür bir ilişki 
yaratmak için önce yavru ve sonra ebeveyn obje seçilir. Edit>Parent komutuna tıklanır. Anahtar obje (son 
seçilen) ebeveyn obje olarak atanır. Ungroup komutu ebeveyn ve yavru objeyi ayırır. 
 
ÖRNEK: EBEVEYN OBJELER 
 
1‐Elparmak.mb dosyasını açın. 
 
2‐En son el olacak şekilde shift tuşuyla tüm parmakları seçin. 
 
3‐Edit>Parent komutu eli ebeveyn parmakları ise yavru konumuna getirir. 
 
4‐Move aracı ile hareket ettirildiğinde parmaklar da onunla birlikte hareket edecektir. Aynı işlem parmaklara 
uygulandığında ise parmaklar elden bağımsız hareket edebilmektedir. 
 

Snap Yapma ve Hizalama 
 
Objeleri kesin yerlerine konumlandırmak amacıyla bu özelliklerden faydanılır. Snap özelliğinin devreye girmiş 
olduğu değiştiricinin ortasındaki karenin daireye dönüşmesinden anlaşılabilir. 
 
Gridleri kullanmak 
 
Maya ilk açıldığında geçerli grid gröünüm panelinde görünür. Display>Grid ile geçerli grid sistemi açılıp 
kapatılabilir. Buradaki komutu seçenek kutusuna tıklanarak grid ayarlarına ulaşılır: 
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Grid aralıkları, rengi ve gösterim biçimi ile ilgili 
ayarlar burada yapılabilir. 
 
Length and Width: Toplam gridin ¼’ünün 
büyüklüğünü belirler: 
 
Grid Lines Every: Her kaç birimde bir grid 
kullanılacağını tanımlar. Buradaki değer 5’dir. 
Her 5 cm’de bir grid ekle olarak algılanabilir. 
 
Subdivisions: Her bir gridin ne kadarlık bir 
bölümlemeye ayrılacağını belirler. Daha iyi 
algılamak için Grid Lines rengi değiştirilebilir. 
 
 
 
 
 
 
 
 
 
 
 
 
 
NOT: Display menüsü altında bulunan Grid’den 
onay işareti kaldırılarak ekrandaki gridler 
kaldırılabilir. 
 
NOT:  
 

 

 

Geçerli Ölçü Birimi 
 
Maya’da uzaklıklar birim olarak ölçülür. Her birimin hangi ölçüye karşılık geleceği  
Windows > Settings/Preferences > Preferences  altında Settings kısmında saptanır. Burada geçerli ölçü cm’dir. 
 

 
 

Objelere Snap Yapmak 
 
Move aracı seçiliyken seçili objeyi spesifik bir grid noktasına, bir eğriye ve yüzey nokatalarına Status satırındaki 
snap düğmeler aktifken snap etmek mümkündür. Bu işlem için birden fazla snap düğmesi işaretlenebilir.  
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Mouse orta düğmesine basıp ve doğru snap modu aktif halde mouse snap noktası hareket ettirilerek  spesifik 
bir noktaya ayrıca snap yapılabilir. 
 
NOT: Gridlere snap yapmak için X tuşu, eğrilere snap için C tuşu ve nokta snapi için V tuşuna basılabilir. 
 
ÖRNEK: SNAP TO CURVES 
 
1‐kolye.mb dosyasını açın. 
 
2‐Kalbe tıklayıp seçin. 
 
3‐Status satırındaki Snap to curves düğmesine tıklayıp aktif yapın. 
 
4‐Move aracını seçip eğriye orta mouse düğmesi ile tıklayıp taşınarak eğriye kilitlenmesi sağlanır. Orta mouse 
düğmesi basılı tutulup kalp hareket ettirildiğinde eğri üzerinde hareket edecektir. 
 
Canlı (live) objeye snap yapmak 
 

Modify>Make Live komutu ile taşınan objelerin canlı objenin yüzeyine snap 
olması sağlanabilir. Canlı obje koyu yeşille gösterilir. Modify>Make Not Live 

komutu objeyi tekrar normal hale dönüştürür. Bu iş için   simgesi de 
kullanılabilir 
 

 
ÖRNEK: LIVE OBJECT 
 
1‐BasitKup.mb dosyasını açın. 
 
2‐Küp seçilerek Modify>Live Object uygulanır. 
 
3‐Küre seçilip kübün herhangi bir köşesine konur.  
 
4‐(y kilitli olarak) Küre Move aracı ile hareket ettirildiğinde küpün dışına 
taşamadığı görülecektir (objeyi merkezinden tutarak hareket ettir). 
 
5‐Edit>Duplicate komutunu uygulayarak küreyi küpün tüm köşelerine 
aşağıdaki gibi Move komutu ile taşıyın. 
 
6‐Seçimi bırakarak Modify>Make Not Live komutu ile kübü ilk haline 
döndürürüz. 
 

 

 

 



BS502 SANAT ve TASARIMDA BİLGİSAYAR I 
Mimar Sinan Güzel Sanatlar Üniversitesi, Enformatik Bölümü 
Doç. Dr. Salih OFLUOĞLU 
 

 31

Hizalamak 
 
Objeleri hizalamak 
 
İki ya da daha fazla obje seçiliyken Modify>Snap Align Objects menü komutuyla obje veya nokta referanslı 
alarak objeler hizalanabilir. Align Objects iletişim kutusu objeleri Min, Mid, Max, Dist veya  
her bir eksenin stack (yığın?) hizalar. Align aracı görünüm panelinde çeşitli hizalama simgesi bulundurur. Bu 
simgelerden birini seçmek seçili objeyi hizalar. Tüm seçili objeler anahtar obje ile hizalanır. 
 
Nokta hizalamak 
 
Bileşen modunda hizalamak istenilen her bir objedeki bir, iki veya üç nokta seçilir. Modify>Snap Align 
Objects>Point to Point, 2 Points to Points veya 3 Points to 3 Points menü komutları seçilerek seçili nokataları 
kullanarak objeler hizalanır.  
 
Point to Point: İki objeyi seçilen noktasından birleştirir. İlk seçilen nesne diğer nesnenin olduğu yere taşınır. 
 

    
 
2 Points to Points: İki objeyi seçilen iki noktasından birleştirir.  
 

     
 
 
NOT: Nokta hizalama seçeneklerini kullanmak için seçili noktalar yaklaşık olarak aynı uzaklıkta olmalıdır. 
 
Yüzeyleri birbirine snap etme 
 
Modify>Snap Align Objects>Snap Together komutu kullanarak objeler hizalanabilir. Bu araç seçili objenin 
yüzeyi üzerinde imleci hareket ettirip, tıklamaya yarar. Ok biçimli imleç yüzeyden yüzeyden uzaklaşır. 
 
İkinci objeye tıklama yüzey üzerinde hareket ettirip bağlantının yapıldığı yeri bulmaya yarar. Çizgi iki yüzeyi 
tanımlanan bağlantı noktalarından bağlar. Enter tuşuna tıklanarak işlem tamamlanır.  
 

 Snap noktalarını poligon nesnelerin merkezine sınırlandırır. 
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ÖRNEK: ALIGN TOOL 
 
1‐HizasızHarfler.mb dosyasını açınız. 
 
2‐M harfine tıklayın. 
 
3‐ Modify>Snap Align Objects>Align Tool komutunu seçin. 
 
4‐Shift tuşunu basılı tutup, diğer harflerin üst kısımlarına tıklayın. Bu işlem sonrasında ekranda açık mavi 
hizalama simgeleri belirir. 
 
5‐Align Bottom ikonuna basarak harfleri hizalayın. 
 

       
 
6‐Önce Y seçilip Modify>Snap Align Objects>Align Tool ile a ya tıklanılır. Sonrasında y a hizasına getirilir. 
 

       
 
ÖRNEK:  TRANSFORMASYON/DUPLICATE/ALIGN/PARENTING 
 
OBJE YARATMA 
1‐Create>Nurbs Primitives>Cylinder ile bir silindir oluşturun. 
2‐Dörtlü görünüm paneline geçin. 
3‐1 tuşuna basarak proje için en düşük çözünürlüğü kullanın. 
 
OBJE ÇOĞALTMA ve TRANFORMASYONU 
4‐channel box’ta rotateZ niteliğini 90 yapın. 
5‐Edit>Duplicate ile objenin bir kopyasnı yarat. 
6‐Scale aracı ile objeyi büyült. 
7‐Edit>Duplicate ile objenin bir kopyasını daha yarat. 
8‐Move aracı ile bu yeni kopyayı X (istikametinde) oluştur. 
9‐Top görünütüsünda şekli ortalamak için gerekirse öteleyin 
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OBJE HİZALAMA 
10‐Orijinal silindiri seç 
11‐Scale aracı ile yeşil Y ekesneii sola doğru sürükle.  
12‐Shift tuşu ile yanındaki slindiri seçin.  
13‐Modify>Snap Align Objects>Align tool ile seçili iki silindirin uçlarını eşitleyin. 
14‐Diğer taraftaki slindir ve küçük silindiri seçin. Align ikonu ile iki silindirin ucunu eşitleyiniz. 
 
EBEVEYN OBJELER 
15‐Dıştaki iki silindiri seçin 
16‐Shif tuşu ile de ince silindiri seçin. 
17‐Edit>Parent komutunu kullan 
 
 

Nodlar ve Nitelikler 
 
Görünüm panelinde görsel görümleri haricinde her obje bir nod olarak temsil edilir. Bu nodlar Outliner ve 
Hypergraph ile görüntülenebilir. Her nod nodun özelliğini tanımlayan nitelikler bulundurur. Örneğin her obje 
pozisyonu ile bilgiyi içeren transform noduna sahiptir. Seçili nodu veri girilebilen nitelikleri Channel Kutusu’nda 
ve tüm nodları ise Nitelik Editöründe görüntülenebilir. 
 
Maya farklı nod tipleri bulundurur. Transform nodu konum, dönme ve boyut bilgilerini, rendering nodu objenin 
görünümü ile ilgili malzeme ve doku bilisini, ışık nodu sahnedeki ışıklar hakkında bilgi içerir. 
 
Nodlarla çalışmak 
 

 

Bir objenin yavru nodları Channel kutusundan izlenebilir. Yavru nodlar 
dışında Status satırındaki düğmeleri kullanarak bir nodun tüm girdi ve çıktı 
nodları seçilebilir. Tüm bu ilişkili nodlar Attribute (nitelik) editörün’nde ayrıca 
sekmeler olarak görülebilir. Attribute Editörü Window>Attribute Editor 
yoluyla veya Status Satırı sağ sonundaki Show Attribute Editor düğmesi ile 
erişilebilir. 
 

 
 
Outline’da nodları shane hiyerarşisi olarak görüntülemek 
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Tüm sahne nodlarını hiyerarşik bir liste olarak görüntülemek için 
Window>Outline yoluyla Outliner açılır. Outliner ebeveynleri altında tüm yavru 
objeleri gösterir. Burada ayrıca gizli görünüm kameraları ve geçerli ışıklar gibi 
tüm gizli objelerde yer alır. Outliner obje seçimi için de kolay bir yöntemdir. 
 

 
 
 
Hypergraph ile bağlılığı (dependency) görüntüleme  
 
Hypergraph nodları görmenin bir başka yoludur. Hypergraph yoluyla nodlar Sahne Hiyerarşisi (scene hierarchy) 
veya Girdi ve Çıktı Bağlantıları (Input Output Connections)  olarak iki şekilde görüntülenebilir. Her iki modda da 
nodlar küçük kutular olarak gösterilir ve farklı nodlar arasında bağalantılar bağlayıcı çizgilerle ifade edilir. 
 

 
 

 

Sahne Hiyerarşisi  Girdi ve Çıktı Bağlantıları
 
NOT: Altt + orta mouse düğmesi tıklaması ve Alt+sağ mouse tıklaması ile Hypergraph’ta öteleme ve zoom 
yapılabilir. F tuşu kullanılarak ayrıca seçili nodlara odaklanılabilir. 
 
Nitelikleri düzenlemek 
 
Objeyle ilişkili tüm veri girilebilir nitelikler Channel Kutusunda görüntülenmektedir. Ancak bu toplam niteliklerin 
sadece bir kısmıdır. Tüm nitelikler Attribute Editor’de görüntülenebilir. Mor renki geriplana sahip nitelikler diğer 
nitelikler tarafından kontrol edilirler ve değiştirilemezler. Shift yardımıyla birden fazla nitelik seçerek değerleri 
değiştirilebilir. 
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Yapılan hatalar geri al komutu ile düzeltilebilir. Son kullanılan komutun 
tekrar edilmesi için Edit menüsünden Repeat seçilebilir. 
Edit>Recent>Commands en son kullanılan komutlara ilişkin bir kutu açar. 
Burada iptal edilmek istenen komutlar tek tek seçilebilir ve geri alınabilir. 
 

 
Construction history’i silmek 
 
Maya’da tüm kullanılan komutlar ön belleğe (cache) yapım geçmişi olarak konur. Burada biriken bilgiler 
zamanla sistemin yavaşlamasına sebep olabilir. Bir objenin yapım geçmişini Edit>Delete by Type>History ile 
silebilir ve basitleştirebilirsiniz. Bu eğriler ve yüzeyler arasındaki bağlatıyı kaldırır, ancak sonuçta daha 
basitleştirilmiş bir obje elde edilir. 
 
 
 
 


